summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-20 21:23:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 10:28:23 +0100
commit57d851ef6924085f05624ff7d34340ea2a94badd (patch)
tree76635370ab9dabfb48157b12949d71ac442cd3fb /dev-libs/grantlee/files
parentsys-cluster/slurm: re-introduce sview disabling (diff)
downloadgentoo-57d851ef6924085f05624ff7d34340ea2a94badd.tar.gz
gentoo-57d851ef6924085f05624ff7d34340ea2a94badd.tar.bz2
gentoo-57d851ef6924085f05624ff7d34340ea2a94badd.zip
dev-libs/grantlee: 0.5.2 version bump
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/grantlee/files')
-rw-r--r--dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch9
-rw-r--r--dev-libs/grantlee/files/grantlee-5.2.0-slot.patch67
2 files changed, 73 insertions, 3 deletions
diff --git a/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
index a25f52b3c63d..b35dc46586e5 100644
--- a/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
+++ b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
@@ -1,6 +1,9 @@
-diff -ruN grantlee-0.3.0.orig/CMakeLists.txt grantlee-0.3.0/CMakeLists.txt
---- grantlee-0.3.0.orig/CMakeLists.txt 2012-11-01 21:14:18.000000000 +0100
-+++ grantlee-0.3.0/CMakeLists.txt 2013-03-09 12:25:56.498096399 +0100
+Do not make linker warnings fatal.
+
+Gentoo-bug: 430968
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -62,8 +62,8 @@
endif()
diff --git a/dev-libs/grantlee/files/grantlee-5.2.0-slot.patch b/dev-libs/grantlee/files/grantlee-5.2.0-slot.patch
new file mode 100644
index 000000000000..9490df2327ec
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-5.2.0-slot.patch
@@ -0,0 +1,67 @@
+From 0bf2a3f667a958b3cc7859cc2fe60ca8a7ccac08 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 30 Nov 2019 11:55:33 +0100
+Subject: [PATCH] Install headers to a custom location to permit slotting
+
+That was previously necessary with Qt4 version, let's keep it while
+Qt6 is around the corner.
+
+Amended with target_include_directories fix by jospezial.
+
+---
+ templates/lib/CMakeLists.txt | 5 +++--
+ textdocument/lib/CMakeLists.txt | 5 +++--
+ 2 files changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
+index 5058481..3ef29a4 100644
+--- a/templates/lib/CMakeLists.txt
++++ b/templates/lib/CMakeLists.txt
+@@ -101,6 +101,7 @@ if (Qt5Qml_FOUND)
+
+ target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
+ target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
++ target_include_directories(Grantlee_Templates INTERFACE "$<INSTALL_INTERFACE:include/grantlee5>")
+ target_link_libraries(Grantlee_Templates
+ PRIVATE Qt5::Qml
+ )
+@@ -152,10 +153,10 @@ install(FILES
+ token.h
+ util.h
+ variable.h
+- DESTINATION include/grantlee COMPONENT Templates
++ DESTINATION include/grantlee5/grantlee COMPONENT Templates
+ )
+
+ install(FILES
+ grantlee_templates.h
+- DESTINATION include COMPONENT Templates
++ DESTINATION include/grantlee5 COMPONENT Templates
+ )
+diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
+index 2c5a96f..c42d32a 100644
+--- a/textdocument/lib/CMakeLists.txt
++++ b/textdocument/lib/CMakeLists.txt
+@@ -34,6 +34,7 @@ if (CMAKE_GENERATOR MATCHES "Visual Studio")
+ )
+ endforeach()
+ endif()
++target_include_directories(Grantlee_TextDocument INTERFACE "$<INSTALL_INTERFACE:include/grantlee5>")
+
+ target_link_libraries(Grantlee_TextDocument
+ PUBLIC Qt5::Gui
+@@ -59,10 +60,10 @@ install(FILES
+ texthtmlbuilder.h
+ mediawikimarkupbuilder.h
+ ${CMAKE_CURRENT_BINARY_DIR}/grantlee_textdocument_export.h
+- DESTINATION include/grantlee COMPONENT TextDocument
++ DESTINATION include/grantlee5/grantlee COMPONENT TextDocument
+ )
+
+ install(FILES
+ grantlee_textdocument.h
+- DESTINATION include COMPONENT TextDocument
++ DESTINATION include/grantlee5 COMPONENT TextDocument
+ )
+--
+2.24.0