summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-23 20:05:22 +0100
committerSam James <sam@gentoo.org>2023-04-23 20:05:22 +0100
commit7b275b0494c46be76ee85251716d5f7e3dc0fddf (patch)
tree03a168ca6a2cd44a11c1c3ddcbe90e82c77f1e11 /dev-libs/elfutils
parentdev-util/patchelf: Add missing ebuild (diff)
downloadgentoo-7b275b0494c46be76ee85251716d5f7e3dc0fddf.tar.gz
gentoo-7b275b0494c46be76ee85251716d5f7e3dc0fddf.tar.bz2
gentoo-7b275b0494c46be76ee85251716d5f7e3dc0fddf.zip
dev-libs/elfutils: fix tests w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/elfutils-0.189-r1.ebuild1
-rw-r--r--dev-libs/elfutils/files/elfutils-0.189-clang16-tests.patch26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/elfutils/elfutils-0.189-r1.ebuild b/dev-libs/elfutils/elfutils-0.189-r1.ebuild
index 285cb3c8c192..16bea52ed18d 100644
--- a/dev-libs/elfutils/elfutils-0.189-r1.ebuild
+++ b/dev-libs/elfutils/elfutils-0.189-r1.ebuild
@@ -45,6 +45,7 @@ BDEPEND="
PATCHES=(
"${WORKDIR}"/${PN}-0.187-patches/
"${FILESDIR}"/${P}-configure-bashisms.patch
+ "${FILESDIR}"/${P}-clang16-tests.patch
)
src_unpack() {
diff --git a/dev-libs/elfutils/files/elfutils-0.189-clang16-tests.patch b/dev-libs/elfutils/files/elfutils-0.189-clang16-tests.patch
new file mode 100644
index 000000000000..8dede51cbb23
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.189-clang16-tests.patch
@@ -0,0 +1,26 @@
+https://sourceware.org/git/?p=elfutils.git;a=commit;h=51373aa9a77ef53d237edc1af664efcbb49f1bf5
+
+From 51373aa9a77ef53d237edc1af664efcbb49f1bf5 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Sat, 22 Apr 2023 21:37:09 +0200
+Subject: [PATCH] testsuite: Avoid C99 compatibility issues in
+ run-native-test.sh
+
+Include <unistd.h> for the pause function, and add the return type
+of main. Avoids an implicit function declaration and implicit int.
+
+Signed-off-by: Florian Weimer <fweimer@redhat.com>
+--- a/tests/run-native-test.sh
++++ b/tests/run-native-test.sh
+@@ -27,7 +27,8 @@
+ # in all builds.
+
+ tempfiles native.c native
+-echo 'main () { while (1) pause (); }' > native.c
++printf '#include <unistd.h>\nint main (void) { while (1) pause (); }\n' \
++ > native.c
+
+ native=0
+ kill_native()
+--
+2.31.1