summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-05-26 11:12:35 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-05-26 11:13:39 +0300
commit13e2cb1c2f57fee406c4852b1e2d0c5eca0e873f (patch)
tree4a1c55683718122823112cf9e82003c4b2bccc81 /dev-libs/botan/botan-2.5.0.ebuild
parentsys-process/cronie: Removed old. (diff)
downloadgentoo-13e2cb1c2f57fee406c4852b1e2d0c5eca0e873f.tar.gz
gentoo-13e2cb1c2f57fee406c4852b1e2d0c5eca0e873f.tar.bz2
gentoo-13e2cb1c2f57fee406c4852b1e2d0c5eca0e873f.zip
dev-libs/botan: cleanup
Bug: https://bugs.gentoo.org/652910 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/botan/botan-2.5.0.ebuild')
-rw-r--r--dev-libs/botan/botan-2.5.0.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/dev-libs/botan/botan-2.5.0.ebuild b/dev-libs/botan/botan-2.5.0.ebuild
deleted file mode 100644
index 53a794a7db56..000000000000
--- a/dev-libs/botan/botan-2.5.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit multilib python-r1 toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="https://botan.randombit.net/"
-SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
-
-KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~ppc-macos"
-SLOT="2/5" # soname version
-LICENSE="BSD"
-IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
- zlib? ( >=sys-libs/zlib-1.2.3 )
- boost? ( >=dev-libs/boost-1.48 )
- lzma? ( app-arch/xz-utils )
- sqlite? ( dev-db/sqlite:3 )
- ssl? (
- !libressl? ( dev-libs/openssl:0=[bindist=] )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${RDEPEND}
- dev-lang/python:*
- doc? ( dev-python/sphinx )"
-
-src_configure() {
- local disable_modules=()
- use boost || disable_modules+=( "boost" )
- use bindist && disable_modules+=( "ecdsa" )
- elog "Disabling modules: ${disable_modules[@]}"
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- local myos=
- case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
- esac
-
- local pythonvers=()
- if use python; then
- append() {
- pythonvers+=( ${EPYTHON/python/} )
- }
- python_foreach_impl append
- fi
-
- CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
- --prefix="${EPREFIX}/usr" \
- --libdir=$(get_libdir) \
- --docdir=share/doc \
- --cc=gcc \
- --os=${myos} \
- --cpu=${CHOSTARCH} \
- --with-endian="$(tc-endian)" \
- --without-doxygen \
- $(use_with bzip2) \
- $(use_with lzma) \
- $(use_with sqlite sqlite3) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- $(use_with boost) \
- $(use_with doc sphinx) \
- $(use_with doc documentation) \
- $(use_enable static-libs static-library) \
- --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
- --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
- || die "configure.py failed"
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
-}
-
-src_install() {
- default
- use python && python_foreach_impl python_optimize
-}