summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 21:30:23 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 21:34:47 +0100
commit9aa9a97bac12dfec6e47c5061812051deb1610d9 (patch)
treec48bca8ab1ce0ec278fc22b092ed90df5f4d7ea8 /dev-lang
parentdev-lang/icc: Migrate from LINGUAS to L10N. (diff)
downloadgentoo-9aa9a97bac12dfec6e47c5061812051deb1610d9.tar.gz
gentoo-9aa9a97bac12dfec6e47c5061812051deb1610d9.tar.bz2
gentoo-9aa9a97bac12dfec6e47c5061812051deb1610d9.zip
dev-lang/ifc: Migrate from LINGUAS to L10N.
Update blocker against icc, it needs to block only when l10n_ja is enabled for both packages. (Also, the blocker was wrong before, as it was against ifc itself.) Bug: https://bugs.gentoo.org/476330 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ifc/ifc-13.1.5.192.ebuild10
-rw-r--r--dev-lang/ifc/ifc-14.0.3.174.ebuild10
-rw-r--r--dev-lang/ifc/ifc-15.0.6.233.ebuild10
3 files changed, 15 insertions, 15 deletions
diff --git a/dev-lang/ifc/ifc-13.1.5.192.ebuild b/dev-lang/ifc/ifc-13.1.5.192.ebuild
index 7ff5dd0df06d..4651e5c84c65 100644
--- a/dev-lang/ifc/ifc-13.1.5.192.ebuild
+++ b/dev-lang/ifc/ifc-13.1.5.192.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,11 +13,11 @@ inherit intel-sdp
DESCRIPTION="Intel FORTRAN Compiler"
HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
-IUSE="linguas_ja"
+IUSE="l10n_ja"
KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
-DEPEND="!dev-lang/ifc[linguas_jp]"
-RDEPEND="${DEPEND}
+# avoid file collision with icc #476330
+RDEPEND="l10n_ja? ( !dev-lang/icc[l10n_ja(-)] !dev-lang/icc[linguas_ja(-)] )
~dev-libs/intel-common-${PV}[compiler,multilib=]"
INTEL_BIN_RPMS="compilerprof compilerprof-devel"
@@ -26,7 +26,7 @@ INTEL_DAT_RPMS="compilerprof-common"
CHECKREQS_DISK_BUILD=375M
src_install() {
- if ! use linguas_ja; then
+ if ! use l10n_ja; then
find "${S}" -type d -name ja_JP -exec rm -rf '{}' + || die
fi
intel-sdp_src_install
diff --git a/dev-lang/ifc/ifc-14.0.3.174.ebuild b/dev-lang/ifc/ifc-14.0.3.174.ebuild
index 2fb00bb8a9b9..ccac93c167cb 100644
--- a/dev-lang/ifc/ifc-14.0.3.174.ebuild
+++ b/dev-lang/ifc/ifc-14.0.3.174.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,11 +14,11 @@ inherit intel-sdp
DESCRIPTION="Intel FORTRAN Compiler"
HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
-IUSE="linguas_ja"
+IUSE="l10n_ja"
KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
-DEPEND="!dev-lang/ifc[linguas_jp]"
-RDEPEND="${DEPEND}
+# avoid file collision with icc #476330
+RDEPEND="l10n_ja? ( !dev-lang/icc[l10n_ja(-)] !dev-lang/icc[linguas_ja(-)] )
~dev-libs/intel-common-${PV}[compiler,multilib=]"
INTEL_BIN_RPMS="compilerprof compilerprof-devel"
@@ -27,7 +27,7 @@ INTEL_DAT_RPMS="compilerprof-common"
CHECKREQS_DISK_BUILD=375M
src_install() {
- if ! use linguas_ja; then
+ if ! use l10n_ja; then
find "${S}" -type d -name ja_JP -exec rm -rf '{}' + || die
fi
intel-sdp_src_install
diff --git a/dev-lang/ifc/ifc-15.0.6.233.ebuild b/dev-lang/ifc/ifc-15.0.6.233.ebuild
index 818272839d41..fe1be6319ab0 100644
--- a/dev-lang/ifc/ifc-15.0.6.233.ebuild
+++ b/dev-lang/ifc/ifc-15.0.6.233.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,11 +14,11 @@ inherit intel-sdp
DESCRIPTION="Intel FORTRAN Compiler"
HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
-IUSE="linguas_ja"
+IUSE="l10n_ja"
KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
-DEPEND="!dev-lang/ifc[linguas_jp]"
-RDEPEND="${DEPEND}
+# avoid file collision with icc #476330
+RDEPEND="l10n_ja? ( !dev-lang/icc[l10n_ja(-)] !dev-lang/icc[linguas_ja(-)] )
~dev-libs/intel-common-${PV}[compiler,multilib=]"
INTEL_BIN_RPMS="compilerprof compilerprof-devel"
@@ -27,7 +27,7 @@ INTEL_DAT_RPMS="compilerprof-common compilerprof-vars"
CHECKREQS_DISK_BUILD=375M
src_install() {
- if ! use linguas_ja; then
+ if ! use l10n_ja; then
find "${S}" -type d -name ja_JP -exec rm -rf '{}' + || die
fi