summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-23 11:00:15 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-23 11:00:15 -0500
commit7da3980f6f899c200216d1f91a9a3ab92b0f7800 (patch)
tree6f896399803ea4d48289459eb0c7abbfe662ccce /dev-lang
parentdev-lang/go: add back the bdepend for dev-lang/go (diff)
downloadgentoo-7da3980f6f899c200216d1f91a9a3ab92b0f7800.tar.gz
gentoo-7da3980f6f899c200216d1f91a9a3ab92b0f7800.tar.bz2
gentoo-7da3980f6f899c200216d1f91a9a3ab92b0f7800.zip
dev-lang/go: remove extraneous file
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/x28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-lang/go/x b/dev-lang/go/x
deleted file mode 100644
index 14d7827f06b0..000000000000
--- a/dev-lang/go/x
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
-index 635b905c4d9..eb74459d848 100644
---- a/dev-lang/go/go-9999.ebuild
-+++ b/dev-lang/go/go-9999.ebuild
-@@ -40,7 +40,9 @@ SLOT="0/${PV}"
- IUSE="gccgo"
-
- BDEPEND="gccgo? ( >=sys-devel/gcc-5[go(-)] )
-- !gccgo? ( >=dev-lang/go-bootstrap-1.13.6 )"
-+ !gccgo? ( ||(
-+ dev-lang/go
-+ dev-lang/go-bootstrap-1.13.6 ) )"
- RDEPEND="!<dev-go/go-tools-0_pre20150902"
-
- # These test data objects have writable/executable stacks.
-@@ -145,8 +147,11 @@ src_compile()
- ln -s "${go_binary}" "${GOROOT_BOOTSTRAP}/bin/go" || die
- elif has_version -b dev-lang/go-bootstrap; then
- export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go-bootstrap"
-+ elif has_version -b dev-lang/go; then
-+ export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go"
- else
-- die "Should not be here, please report a bug"
-+ eerror "Go cannot be built without go or go-bootstrap installed"
-+ die "Should not be here, please report a bug.
- fi
-
- export GOROOT_FINAL="${EPREFIX}"/usr/lib/go