summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-15 11:47:56 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-15 11:49:34 -0400
commit6162fb237663bbe61114cf13951715c141d51bba (patch)
tree6e90f498c1b661403fc87caf0fa5c6a01d1060c6 /dev-lang
parentsys-apps/file: add lzip support to live (diff)
downloadgentoo-6162fb237663bbe61114cf13951715c141d51bba.tar.gz
gentoo-6162fb237663bbe61114cf13951715c141d51bba.tar.bz2
gentoo-6162fb237663bbe61114cf13951715c141d51bba.zip
dev-lang/R: backport a fix for a broken test.
This isn't a critical fix by any means, but otherwise we're likely to forget to re-enable this test when R-4.2.2 comes out. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/R-4.2.1.ebuild14
-rw-r--r--dev-lang/R/files/R-4.2.1-reg-packages-testfix.patch25
2 files changed, 30 insertions, 9 deletions
diff --git a/dev-lang/R/R-4.2.1.ebuild b/dev-lang/R/R-4.2.1.ebuild
index cfb2a07ff6bc..1ee01869a453 100644
--- a/dev-lang/R/R-4.2.1.ebuild
+++ b/dev-lang/R/R-4.2.1.ebuild
@@ -71,10 +71,11 @@ BDEPEND="
test? ( virtual/latex-base )"
PATCHES=(
- "${FILESDIR}"/${PN}-3.4.1-parallel.patch
- "${FILESDIR}"/${PN}-3.4.1-rmath-shared.patch
- "${FILESDIR}"/${PN}-3.6.2-no-LDFLAGS-in-libR-pkg-config.patch
- "${FILESDIR}"/${PN}-3.6.2-no-gzip-doc.patch
+ "${FILESDIR}"/R-3.4.1-parallel.patch
+ "${FILESDIR}"/R-3.4.1-rmath-shared.patch
+ "${FILESDIR}"/R-3.6.2-no-LDFLAGS-in-libR-pkg-config.patch
+ "${FILESDIR}"/R-3.6.2-no-gzip-doc.patch
+ "${FILESDIR}"/R-4.2.1-reg-packages-testfix.patch
)
pkg_pretend() {
@@ -108,11 +109,6 @@ src_prepare() {
sed -e 's:\.\./manual/:manual/:g' \
-i $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
- # Disable this test until it passes again,
- # https://bugs.r-project.org/show_bug.cgi?id=18338
- sed -e 's/ reg-packages.R / /' \
- -i tests/Makefile.common || die
-
use lapack &&
export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
diff --git a/dev-lang/R/files/R-4.2.1-reg-packages-testfix.patch b/dev-lang/R/files/R-4.2.1-reg-packages-testfix.patch
new file mode 100644
index 000000000000..f5fe9667ad67
--- /dev/null
+++ b/dev-lang/R/files/R-4.2.1-reg-packages-testfix.patch
@@ -0,0 +1,25 @@
+diff --git a/tests/reg-packages.R b/tests/reg-packages.R
+index c9962ce..2d36d1e 100644
+--- a/tests/reg-packages.R
++++ b/tests/reg-packages.R
+@@ -260,7 +260,8 @@ stopifnot(exprs = {
+ (lenN <- length(print(iN <- grep("^[1-9][0-9]:", tlines)))) >= 2
+ iN - iw == seq_len(lenN) # these (3) lines come immediately after 'Warning',
+ ## and "related" to the some 'missing .. paren' above:
+- 8 <= print(iw - i) & iw - i <= 20 # see ~14
++ !is.na(ierr <- as.integer(substr(print(tlines[iN[1]]), 1, 2)))
++ 8 <= print(ierr - i) & ierr - i <= 14 # see 11
+ }) ## failed in R <= 4.1.1
+
+
+@@ -495,8 +496,8 @@ checkMatrix(ap, 4)
+
+
+ ## clean up
+-rmL <- c("myLib", if(has.symlink) "myLib_2", "myTst", file.path(pkgPath),
+- oldpkgdir, newpkgdir, repodir, backupPfiles)
++rmL <- c("myLib", if(has.symlink) "myLib_2", "myTst", "myTst2",
++ "PR17501.Rcheck")
+ if(do.cleanup) {
+ for(nm in rmL) unlink(nm, recursive = TRUE)
+ } else {