summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-04 19:09:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-04 19:45:27 +0100
commit4816e022990f3dcdac7e11c03c521cad7ceca9fa (patch)
tree3677454084da659b9405ee19032765da5216aff7 /dev-lang
parentdev-lang/python: Backport configure check fix to 2.7.18_p16 (diff)
downloadgentoo-4816e022990f3dcdac7e11c03c521cad7ceca9fa.tar.gz
gentoo-4816e022990f3dcdac7e11c03c521cad7ceca9fa.tar.bz2
gentoo-4816e022990f3dcdac7e11c03c521cad7ceca9fa.zip
dev-lang/python: Use PYVER for addwrite/addpredict calls
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.8_p2.ebuild4
-rw-r--r--dev-lang/python/python-3.11.0_p1.ebuild4
-rw-r--r--dev-lang/python/python-3.12.0_alpha1_p1.ebuild4
-rw-r--r--dev-lang/python/python-3.9.15_p2.ebuild2
4 files changed, 7 insertions, 7 deletions
diff --git a/dev-lang/python/python-3.10.8_p2.ebuild b/dev-lang/python/python-3.10.8_p2.ebuild
index 0b7ad7f2c527..48050825327e 100644
--- a/dev-lang/python/python-3.10.8_p2.ebuild
+++ b/dev-lang/python/python-3.10.8_p2.ebuild
@@ -319,7 +319,7 @@ src_compile() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- addpredict /usr/lib/python3.10/site-packages
+ addpredict "/usr/lib/python${PYVER}/site-packages"
fi
# also need to clear the flags explicitly here or they end up
@@ -364,7 +364,7 @@ src_test() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
# workaround https://bugs.gentoo.org/775416
- addwrite /usr/lib/python3.10/site-packages
+ addwrite "/usr/lib/python${PYVER}/site-packages"
emake test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty || die "emake test failed"
diff --git a/dev-lang/python/python-3.11.0_p1.ebuild b/dev-lang/python/python-3.11.0_p1.ebuild
index ab0050062031..5d7d0355e38c 100644
--- a/dev-lang/python/python-3.11.0_p1.ebuild
+++ b/dev-lang/python/python-3.11.0_p1.ebuild
@@ -326,7 +326,7 @@ src_compile() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- addpredict /usr/lib/python3.11/site-packages
+ addpredict "/usr/lib/python${PYVER}/site-packages"
fi
# also need to clear the flags explicitly here or they end up
@@ -381,7 +381,7 @@ src_test() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
# workaround https://bugs.gentoo.org/775416
- addwrite /usr/lib/python3.11/site-packages
+ addwrite "/usr/lib/python${PYVER}/site-packages"
nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
index 41887948b0bd..8d748fa37b67 100644
--- a/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha1_p1.ebuild
@@ -315,7 +315,7 @@ src_compile() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- addpredict /usr/lib/python3.11/site-packages
+ addpredict "/usr/lib/python${PYVER}/site-packages"
fi
# also need to clear the flags explicitly here or they end up
@@ -370,7 +370,7 @@ src_test() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
# workaround https://bugs.gentoo.org/775416
- addwrite /usr/lib/python3.11/site-packages
+ addwrite "/usr/lib/python${PYVER}/site-packages"
nonfatal emake test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.9.15_p2.ebuild b/dev-lang/python/python-3.9.15_p2.ebuild
index a4f409cd861b..2f8b9cad109e 100644
--- a/dev-lang/python/python-3.9.15_p2.ebuild
+++ b/dev-lang/python/python-3.9.15_p2.ebuild
@@ -313,7 +313,7 @@ src_compile() {
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
- addpredict /usr/lib/python3.9/site-packages
+ addpredict "/usr/lib/python${PYVER}/site-packages"
fi
# also need to clear the flags explicitly here or they end up