summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-07 01:45:37 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-07 01:50:47 +0200
commit1436f8adb49013af4ed0629e04386731767b7bd7 (patch)
tree096f143a978707cffce4b75e3ef9d7e28966c6fc /dev-lang
parentdev-lang/php: filter LTO flags from php-7.x. (diff)
downloadgentoo-1436f8adb49013af4ed0629e04386731767b7bd7.tar.gz
gentoo-1436f8adb49013af4ed0629e04386731767b7bd7.tar.bz2
gentoo-1436f8adb49013af4ed0629e04386731767b7bd7.zip
dev-lang/neko: filter LTO (strict-aliasing)
Closes: https://bugs.gentoo.org/855641 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/neko/neko-2.3.0-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/neko/neko-2.3.0-r1.ebuild b/dev-lang/neko/neko-2.3.0-r1.ebuild
index c078c06afa2c..701f48537ec9 100644
--- a/dev-lang/neko/neko-2.3.0-r1.ebuild
+++ b/dev-lang/neko/neko-2.3.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit flag-o-matic cmake
DESCRIPTION="Neko is a high-level dynamically typed programming language"
HOMEPAGE="https://nekovm.org/"
@@ -38,6 +38,10 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
+ # -Werror=strict-aliasing warnings, bug #855641
+ filter-lto
+ append-flags -fno-strict-aliasing
+
local mycmakeargs=(
-DRUN_LDCONFIG=OFF
-DWITH_NEKOML=ON