summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-07 17:27:11 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-07 17:35:12 +0100
commit2a6c3d2bda86d686021ab67f32a6da9a272056f3 (patch)
treec702a106823d5731632fb1128c9751ec80f3bf22 /dev-lang/rust
parentdev-libs/npth: add ~x86-linux keyword (diff)
downloadgentoo-2a6c3d2bda86d686021ab67f32a6da9a272056f3.tar.gz
gentoo-2a6c3d2bda86d686021ab67f32a6da9a272056f3.tar.bz2
gentoo-2a6c3d2bda86d686021ab67f32a6da9a272056f3.zip
dev-lang/rust: Correct sys-devel/llvm deps to slot :0
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.11.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.12.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.12.1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.13.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.14.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.15.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.15.1.ebuild4
7 files changed, 19 insertions, 19 deletions
diff --git a/dev-lang/rust/rust-1.11.0.ebuild b/dev-lang/rust/rust-1.11.0.ebuild
index 27f9df57de29..0e6d196964a1 100644
--- a/dev-lang/rust/rust-1.11.0.ebuild
+++ b/dev-lang/rust/rust-1.11.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,8 +40,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2:=[multitarget]
- <sys-devel/llvm-3.9.0:=[multitarget] )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2:0=[multitarget]
+ <sys-devel/llvm-3.9.0:0=[multitarget] )
"
DEPEND="${RDEPEND}
diff --git a/dev-lang/rust/rust-1.12.0.ebuild b/dev-lang/rust/rust-1.12.0.ebuild
index 27f9df57de29..0e6d196964a1 100644
--- a/dev-lang/rust/rust-1.12.0.ebuild
+++ b/dev-lang/rust/rust-1.12.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,8 +40,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2:=[multitarget]
- <sys-devel/llvm-3.9.0:=[multitarget] )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2:0=[multitarget]
+ <sys-devel/llvm-3.9.0:0=[multitarget] )
"
DEPEND="${RDEPEND}
diff --git a/dev-lang/rust/rust-1.12.1.ebuild b/dev-lang/rust/rust-1.12.1.ebuild
index 63f7ccd8b2fe..6789e46d191d 100644
--- a/dev-lang/rust/rust-1.12.1.ebuild
+++ b/dev-lang/rust/rust-1.12.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,8 +41,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2
- <sys-devel/llvm-3.10.0 )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2:0
+ <sys-devel/llvm-3.10.0:0 )
"
DEPEND="${RDEPEND}
diff --git a/dev-lang/rust/rust-1.13.0.ebuild b/dev-lang/rust/rust-1.13.0.ebuild
index cd08a8f4714f..73c34e566a45 100644
--- a/dev-lang/rust/rust-1.13.0.ebuild
+++ b/dev-lang/rust/rust-1.13.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,8 +41,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2
- <sys-devel/llvm-3.10.0 )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2:0
+ <sys-devel/llvm-3.10.0:0 )
"
DEPEND="${RDEPEND}
diff --git a/dev-lang/rust/rust-1.14.0.ebuild b/dev-lang/rust/rust-1.14.0.ebuild
index 63f7ccd8b2fe..6789e46d191d 100644
--- a/dev-lang/rust/rust-1.14.0.ebuild
+++ b/dev-lang/rust/rust-1.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,8 +41,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2
- <sys-devel/llvm-3.10.0 )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2:0
+ <sys-devel/llvm-3.10.0:0 )
"
DEPEND="${RDEPEND}
diff --git a/dev-lang/rust/rust-1.15.0.ebuild b/dev-lang/rust/rust-1.15.0.ebuild
index 7074d89aca32..5d7f76787c57 100644
--- a/dev-lang/rust/rust-1.15.0.ebuild
+++ b/dev-lang/rust/rust-1.15.0.ebuild
@@ -41,8 +41,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2
- <sys-devel/llvm-3.10.0 )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2:0
+ <sys-devel/llvm-3.10.0:0 )
"
DEPEND="${RDEPEND}
diff --git a/dev-lang/rust/rust-1.15.1.ebuild b/dev-lang/rust/rust-1.15.1.ebuild
index 7074d89aca32..5d7f76787c57 100644
--- a/dev-lang/rust/rust-1.15.1.ebuild
+++ b/dev-lang/rust/rust-1.15.1.ebuild
@@ -41,8 +41,8 @@ IUSE="clang debug doc libcxx +system-llvm"
REQUIRED_USE="libcxx? ( clang )"
RDEPEND="libcxx? ( sys-libs/libcxx )
- system-llvm? ( >=sys-devel/llvm-3.8.1-r2
- <sys-devel/llvm-3.10.0 )
+ system-llvm? ( >=sys-devel/llvm-3.8.1-r2:0
+ <sys-devel/llvm-3.10.0:0 )
"
DEPEND="${RDEPEND}