summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2020-06-23 18:13:08 +0200
committerKeri Harris <keri@gentoo.org>2020-06-23 18:13:48 +0200
commit155f0f8869defe6c80b2e60ec5ada30334d57189 (patch)
treeff406fad974571d0f43456273f00e7037dd359be /dev-lang/mozart/mozart-2.0.1.ebuild
parentdev-cpp/waylandpp: Fix ‘runtime_error’ is not a member of ‘std’ (diff)
downloadgentoo-155f0f8869defe6c80b2e60ec5ada30334d57189.tar.gz
gentoo-155f0f8869defe6c80b2e60ec5ada30334d57189.tar.bz2
gentoo-155f0f8869defe6c80b2e60ec5ada30334d57189.zip
dev-lang/mozart: patch bootcompiler to work with Scala 2.12
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Keri Harris <keri@gentoo.org>
Diffstat (limited to 'dev-lang/mozart/mozart-2.0.1.ebuild')
-rw-r--r--dev-lang/mozart/mozart-2.0.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/mozart/mozart-2.0.1.ebuild b/dev-lang/mozart/mozart-2.0.1.ebuild
index e6b2dc3f4425..ebd5d3b04736 100644
--- a/dev-lang/mozart/mozart-2.0.1.ebuild
+++ b/dev-lang/mozart/mozart-2.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit cmake-utils java-pkg-2 java-ant-2
-PATCHSET_VER="0"
+PATCHSET_VER="1"
DESCRIPTION="Advanced development platform for intelligent, distributed applications"
HOMEPAGE="http://mozart2.org/"
@@ -28,8 +28,8 @@ DEPEND="${RDEPEND}
dev-java/ant-core
>=virtual/jdk-1.8:=
|| (
- dev-lang/scala
- dev-lang/scala-bin
+ dev-lang/scala:2.12
+ dev-lang/scala-bin:0
)
test? ( dev-cpp/gtest:= )"
@@ -60,7 +60,7 @@ src_configure() {
src_compile() {
if has_version "dev-lang/scala"; then
- EANT_GENTOO_CLASSPATH="scala"
+ EANT_GENTOO_CLASSPATH="scala:2.12"
else
EANT_GENTOO_CLASSPATH="scala-bin"
fi