summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/logtalk/logtalk-2.42.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/logtalk/logtalk-2.42.2.ebuild')
-rw-r--r--dev-lang/logtalk/logtalk-2.42.2.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/dev-lang/logtalk/logtalk-2.42.2.ebuild b/dev-lang/logtalk/logtalk-2.42.2.ebuild
new file mode 100644
index 000000000000..d60b0831d130
--- /dev/null
+++ b/dev-lang/logtalk/logtalk-2.42.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator fdo-mime
+
+DESCRIPTION="Open source object-oriented logic programming language"
+HOMEPAGE="http://logtalk.org"
+MY_PV="lgt$(delete_all_version_separators)"
+SRC_URI="http://logtalk.org/files/${MY_PV}.tar.bz2"
+LICENSE="Artistic-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnupl qupl swipl xsbpl yappl xslt fop"
+
+DEPEND=""
+RDEPEND="
+ gnupl? ( dev-lang/gprolog )
+ qupl? ( !amd64? ( dev-lang/qu-prolog ) )
+ swipl? ( dev-lang/swi-prolog )
+ xsbpl? ( x86? ( dev-lang/xsb ) )
+ yappl? ( dev-lang/yap )
+ xslt? ( dev-libs/libxslt )
+ fop? ( dev-java/fop )
+ ${DEPEND}"
+
+S="${WORKDIR}/${MY_PV}"
+
+src_install() {
+ # Look at scripts/install.sh for upstream installation process.
+ # Install logtalk base
+ mv scripts/logtalk_user_setup.sh integration/
+ mkdir -p "${D}/usr/share/${P}"
+ cp -r compiler configs contributions VERSION.txt \
+ integration library wenv xml libpaths \
+ examples settings.lgt "${D}/usr/share/${P}" \
+ || die "Failed to install files"
+
+ # Install mime file, the database will be updated later
+ insinto /usr/share/mime/packages
+ doins scripts/freedesktop/logtalk.xml
+
+ # Install documentation
+ dodoc BIBLIOGRAPHY.bib CUSTOMIZE.txt INSTALL.txt \
+ LICENSE.txt QUICK_START.txt README.txt \
+ RELEASE_NOTES.txt UPGRADING.txt VERSION.txt
+ dohtml -r manuals/* || die "Failed to install html manual"
+
+ rm -f man/man1/logtalk_backend_select.1
+ rm -f man/man1/logtalk_version_select.1
+ doman man/man1/*.1 || die "Failed to install man pages"
+
+ # Integration symlinks
+ dosym /usr/share/${P}/integration/logtalk_user_setup.sh \
+ /usr/bin/logtalk_user_setup
+ use gnupl && dosym /usr/share/${P}/integration/gplgt.sh \
+ /usr/bin/gplgt
+ use qupl && ! use amd64 && dosym /usr/share/${P}/integration/qplgt.sh \
+ /usr/bin/qplgt
+ use swipl && dosym /usr/share/${P}/integration/swilgt.sh \
+ /usr/bin/swilgt
+ use xsbpl && use x86 && dosym /usr/share/${P}/integration/xsblgt.sh \
+ /usr/bin/xsblgt
+ use yappl && dosym /usr/share/${P}/integration/yaplgt.sh \
+ /usr/bin/yaplgt
+
+ dosym /usr/share/${P}/xml/lgt2xml.sh /usr/bin/lgt2xml
+ use xslt && dosym /usr/share/${P}/xml/lgt2html.sh /usr/bin/lgt2html
+ use xslt && dosym /usr/share/${P}/xml/lgt2txt.sh /usr/bin/lgt2txt
+ use fop && dosym /usr/share/${P}/xml/lgt2pdf.sh /usr/bin/lgt2pdf
+
+ # Install environment files
+ echo "LOGTALKHOME=/usr/share/${P}" > 99logtalk
+ doenvd 99logtalk
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ ewarn "Before running logtalk, users should execute"
+ ewarn "logtalk_user_setup *once*."
+ ewarn "To start logtalk use one of the following:"
+ use gnupl && ewarn "GNU Prolog: /usr/bin/gplgt"
+ use qupl && ! use amd64 && ewarn "Qu Prolog: /usr/bin/qplgt"
+ use swipl && ewarn "SWI Prolog: /usr/bin/swilgt"
+ use xsbpl && use x86 && ewarn "XSB: /usr/bin/xsblgt"
+ use yappl && ewarn "YAP: /usr/bin/yaplgt"
+ ewarn ""
+
+ ewarn "The environment has been set up to make the above"
+ ewarn "integration scripts find files automatically for logtalk."
+ ewarn "Please run 'etc-update && source /etc/profile' to update"
+ ewarn "the environment now, otherwise it will be updated at next"
+ ewarn "login."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}