summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-02-15 16:02:43 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-02-15 16:17:18 +0100
commit35068194f27455a33f8d01638f00c9f6e3b11708 (patch)
tree12d5fccbc353e6a81e4e31b1159ed016d6a555ac /dev-java/gnu-regexp/gnu-regexp-1.1.4-r4.ebuild
parentnet-misc/smb4k: keyword ~riscv (diff)
downloadgentoo-35068194f27455a33f8d01638f00c9f6e3b11708.tar.gz
gentoo-35068194f27455a33f8d01638f00c9f6e3b11708.tar.bz2
gentoo-35068194f27455a33f8d01638f00c9f6e3b11708.zip
dev-java/gnu-regexp: EAPI 8, min java 1.8:*
Bug: https://bugs.gentoo.org/833399 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24197 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-java/gnu-regexp/gnu-regexp-1.1.4-r4.ebuild')
-rw-r--r--dev-java/gnu-regexp/gnu-regexp-1.1.4-r4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/gnu-regexp/gnu-regexp-1.1.4-r4.ebuild b/dev-java/gnu-regexp/gnu-regexp-1.1.4-r4.ebuild
new file mode 100644
index 000000000000..3c28833194c8
--- /dev/null
+++ b/dev-java/gnu-regexp/gnu-regexp-1.1.4-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="gnu.regexp-${PV}"
+
+DESCRIPTION="GNU regular expression package for Java"
+HOMEPAGE="https://savannah.gnu.org/projects/gnu-regexp"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+CDEPEND="dev-java/java-getopt:1"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_SRC_DIR="src"
+
+JAVA_GENTOO_CLASSPATH="java-getopt-1"
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres "${PN}.jar" src -name "*.properties"
+}