summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/dsiutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/dsiutils')
-rw-r--r--dev-java/dsiutils/Manifest1
-rw-r--r--dev-java/dsiutils/dsiutils-1.0.10-r2.ebuild58
-rw-r--r--dev-java/dsiutils/metadata.xml14
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-java/dsiutils/Manifest b/dev-java/dsiutils/Manifest
new file mode 100644
index 000000000000..c26c8879f343
--- /dev/null
+++ b/dev-java/dsiutils/Manifest
@@ -0,0 +1 @@
+DIST dsiutils-1.0.10-src.tar.gz 267700 SHA256 d3eda619ab7f897f9c0aeb4065a5866dc8fa17afbb83e15750f7972bb87444d0 SHA512 32cb9cde72056bbcdfd842011252772ccd3ceb226e44972f5388352ebab9a5ae66d97d4af00078f95033d6ed99fd6a12b82cbd1679a72e1e59ca95409c6e9e35 WHIRLPOOL ece0c1a8f75e24a7291750013a1a7c39d8bd4f0242dc159463547159dc58165e245daae72bb8b54fd9a623701fdab5ccef24819fc9ddce8315329e1d06e13b82
diff --git a/dev-java/dsiutils/dsiutils-1.0.10-r2.ebuild b/dev-java/dsiutils/dsiutils-1.0.10-r2.ebuild
new file mode 100644
index 000000000000..186a075f94bb
--- /dev/null
+++ b/dev-java/dsiutils/dsiutils-1.0.10-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Mish Mash of classes that were initially distributed with mg4j (amount others)"
+HOMEPAGE="http://dsiutils.dsi.unimi.it/"
+SRC_URI="http://dsiutils.dsi.unimi.it/${P}-src.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/commons-io:1
+ dev-java/jsap:0
+ dev-java/log4j:0
+ dev-java/commons-collections:0
+ dev-java/colt:0
+ dev-java/fastutil:5.0
+ dev-java/commons-configuration:0
+ dev-java/commons-lang:2.1
+ dev-java/junit:0"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.5"
+# Failes to build with jdk7 #423519
+DEPEND="${COMMON_DEP}
+ || ( virtual/jdk:1.6 virtual/jdk:1.5 )
+ test? (
+ dev-java/emma:0
+ dev-java/ant-junit:0
+ dev-java/ant-trax:0
+ )"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+JAVA_ANT_CLASSPATH_TAGS+=" javadoc"
+
+EANT_GENTOO_CLASSPATH="commons-io-1,jsap,log4j,commons-collections,colt,fastutil-5.0,commons-configuration,commons-lang-2.1,junit"
+
+EANT_TEST_TARGET="junit"
+EANT_TEST_ANT_TASKS="ant-trax"
+EANT_TEST_EXTRA_ARGS="-Djar.base=/usr/share/emma/lib"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "${P}.jar"
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/it
+}
diff --git a/dev-java/dsiutils/metadata.xml b/dev-java/dsiutils/metadata.xml
new file mode 100644
index 000000000000..706df8c78e0e
--- /dev/null
+++ b/dev-java/dsiutils/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ The DSI utilities are a mish mash of classes accumulated during the last
+ ten years in projects developed at the DSI (Dipartimento di Scienze
+ dell'Informazione, e.g., Information Sciences Department) of the
+ Università degli Studi di Milano. They were originally distributed in
+ several projects (mainly in MG4J) but we finally decided to gather all
+ the material in a single place.
+ </longdescription>
+</pkgmetadata>
+