summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-configuration
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-configuration')
-rw-r--r--dev-java/commons-configuration/Manifest1
-rw-r--r--dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild71
-rw-r--r--dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild68
-rw-r--r--dev-java/commons-configuration/commons-configuration-1.6.ebuild71
-rw-r--r--dev-java/commons-configuration/files/commons-configuration-1.4-gentoo.patch26
-rw-r--r--dev-java/commons-configuration/files/commons-configuration-1.6-gentoo.patch19
-rw-r--r--dev-java/commons-configuration/metadata.xml10
7 files changed, 266 insertions, 0 deletions
diff --git a/dev-java/commons-configuration/Manifest b/dev-java/commons-configuration/Manifest
new file mode 100644
index 000000000000..c423c4c6171e
--- /dev/null
+++ b/dev-java/commons-configuration/Manifest
@@ -0,0 +1 @@
+DIST commons-configuration-1.6-src.tar.gz 559621 SHA256 3874f0c7227874474e538c41f28e2d11584eff3c14323985a1f92da97841cf5b SHA512 5d82b844cf39162976820d030d05afeeec1151aa33bf4353f9ca844e552c55ea26daa1b74158baa31d0677e311e9dd83a1d9721c8d5f4e23d21068c4ca2eeb01 WHIRLPOOL 5ae3d17fbd32d3445e04a8f8eb3ad91e59ae3220cee0f17bb27176a18d2c1ff79e2099b90d828268b8bc3ddeeaacb4fed57df722ad7b0cca97dbe4d5a45d30f6
diff --git a/dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild b/dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild
new file mode 100644
index 000000000000..00ab9c1d6a7b
--- /dev/null
+++ b/dev-java/commons-configuration/commons-configuration-1.6-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Generic interface for reading configuration data from a variety of sources"
+HOMEPAGE="http://commons.apache.org/configuration/"
+SRC_URI="mirror://apache/commons/configuration/source/${P}-src.tar.gz"
+
+# it needs functionality from ant-core, although not providing an ant task
+# the functionality is apparently needed only for 1.4 jdk
+# but I don't feel like adding virtual for this
+COMMON_DEPENDS="
+ >=dev-java/commons-beanutils-1.7.0:1.7
+ >=dev-java/commons-codec-1.3:0
+ >=dev-java/commons-collections-3.1:0
+ >=dev-java/commons-digester-1.8:0
+ >=dev-java/commons-jxpath-1.2:0
+ >=dev-java/commons-lang-2.4:2.1
+ >=dev-java/commons-logging-1.1.1:0
+ java-virtuals/servlet-api:2.5
+ dev-java/ant-core:0"
+
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEPENDS}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPENDS}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Tweak build classpath and don't automatically run tests
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ java-ant_rewrite-classpath
+}
+
+EANT_GENTOO_CLASSPATH="
+ commons-beanutils:1.7
+ commons-codec
+ commons-collections
+ commons-digester
+ commons-jxpath
+ commons-lang:2.1
+ commons-logging
+ servlet-api:2.5
+ ant-core"
+
+# Would need mockobjects with j2ee support which we don't have
+# Check overlay for ebuild with test support
+RESTRICT="test"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ dodoc RELEASE-NOTES.txt || die
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild b/dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild
new file mode 100644
index 000000000000..9b2053d295df
--- /dev/null
+++ b/dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Generic interface for reading configuration data from a variety of sources"
+HOMEPAGE="http://commons.apache.org/configuration/"
+SRC_URI="mirror://apache/commons/configuration/source/${P}-src.tar.gz"
+
+# it needs functionality from ant-core, although not providing an ant task
+# the functionality is apparently needed only for 1.4 jdk
+# but I don't feel like adding virtual for this
+CDEPEND="
+ >=dev-java/commons-beanutils-1.7.0:1.7
+ >=dev-java/commons-codec-1.3:0
+ >=dev-java/commons-collections-3.1:0
+ >=dev-java/commons-digester-1.8:0
+ >=dev-java/commons-jxpath-1.2:0
+ >=dev-java/commons-lang-2.4:2.1
+ >=dev-java/commons-logging-1.1.1:0
+ java-virtuals/servlet-api:3.0
+ dev-java/ant-core:0"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+java_prepare() {
+ # Tweak build classpath and don't automatically run tests
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+EANT_GENTOO_CLASSPATH="
+ commons-beanutils-1.7
+ commons-codec
+ commons-collections
+ commons-digester
+ commons-jxpath
+ commons-lang-2.1
+ commons-logging
+ servlet-api-3.0
+ ant-core"
+
+# Would need mockobjects with j2ee support which we don't have
+# Check overlay for ebuild with test support
+RESTRICT="test"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ dodoc RELEASE-NOTES.txt || die
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-configuration/commons-configuration-1.6.ebuild b/dev-java/commons-configuration/commons-configuration-1.6.ebuild
new file mode 100644
index 000000000000..91b467e6a118
--- /dev/null
+++ b/dev-java/commons-configuration/commons-configuration-1.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=1
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Generic interface for reading configuration data from a variety of sources"
+HOMEPAGE="http://commons.apache.org/configuration/"
+SRC_URI="mirror://apache/commons/configuration/source/${P}-src.tar.gz"
+
+# it needs functionality from ant-core, although not providing an ant task
+# the functionality is apparently needed only for 1.4 jdk
+# but I don't feel like adding virtual for this
+COMMON_DEPENDS="
+ >=dev-java/commons-beanutils-1.7.0:1.7
+ >=dev-java/commons-codec-1.3:0
+ >=dev-java/commons-collections-3.1:0
+ >=dev-java/commons-digester-1.8:0
+ >=dev-java/commons-jxpath-1.2:0
+ >=dev-java/commons-lang-2.4:2.1
+ >=dev-java/commons-logging-1.1.1:0
+ dev-java/servletapi:2.4
+ dev-java/ant-core:0"
+
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPENDS}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPENDS}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Tweak build classpath and don't automatically run tests
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ java-ant_rewrite-classpath
+}
+
+EANT_GENTOO_CLASSPATH="
+ commons-beanutils-1.7
+ commons-codec
+ commons-collections
+ commons-digester
+ commons-jxpath
+ commons-lang-2.1
+ commons-logging
+ servletapi-2.4
+ ant-core"
+
+# Would need mockobjects with j2ee support which we don't have
+# Check overlay for ebuild with test support
+RESTRICT="test"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ dodoc RELEASE-NOTES.txt || die
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-configuration/files/commons-configuration-1.4-gentoo.patch b/dev-java/commons-configuration/files/commons-configuration-1.4-gentoo.patch
new file mode 100644
index 000000000000..19b68cd697bb
--- /dev/null
+++ b/dev-java/commons-configuration/files/commons-configuration-1.4-gentoo.patch
@@ -0,0 +1,26 @@
+--- build.xml.orig 2006-10-13 00:00:17.000000000 +0200
++++ build.xml 2006-10-13 00:02:37.000000000 +0200
+@@ -97,13 +97,13 @@
+ </copy>
+ </target>
+
+- <target name="jar" description="o Create the jar" depends="compile,test">
++ <target name="jar" description="o Create the jar" depends="compile">
+ <mkdir dir="${classesdir}/META-INF"/>
+ <copy file="LICENSE.txt" todir="${metadir}"/>
+ <copy file="NOTICE.txt" todir="${metadir}"/>
+- <copy file="${conf.home}/manifest.mf" todir="${defaulttargetdir}" filtering="on"/>
++ <copy file="${conf.home}/MANIFEST.MF" todir="${defaulttargetdir}" filtering="on"/>
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" basedir="${classesdir}"
+- manifest="${defaulttargetdir}/manifest.mf" excludes="**/package.html">
++ manifest="${defaulttargetdir}/MANIFEST.MF" excludes="**/package.html">
+ </jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+@@ -282,4 +282,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ Chybí znak konce řádku na konci souboru
++</project>
diff --git a/dev-java/commons-configuration/files/commons-configuration-1.6-gentoo.patch b/dev-java/commons-configuration/files/commons-configuration-1.6-gentoo.patch
new file mode 100644
index 000000000000..0cfa8f6511e7
--- /dev/null
+++ b/dev-java/commons-configuration/files/commons-configuration-1.6-gentoo.patch
@@ -0,0 +1,19 @@
+--- build.xml.orig 2006-10-13 00:00:17.000000000 +0200
++++ build.xml 2006-10-13 00:02:37.000000000 +0200
+@@ -97,13 +97,13 @@
+ </copy>
+ </target>
+
+- <target name="jar" description="o Create the jar" depends="compile,test">
++ <target name="jar" description="o Create the jar" depends="compile">
+ <mkdir dir="${classesdir}/META-INF"/>
+ <copy file="LICENSE.txt" todir="${metadir}"/>
+ <copy file="NOTICE.txt" todir="${metadir}"/>
+- <copy file="${conf.home}/manifest.mf" todir="${defaulttargetdir}" filtering="on"/>
++ <copy file="${conf.home}/MANIFEST.MF" todir="${defaulttargetdir}" filtering="on"/>
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" basedir="${classesdir}"
+- manifest="${defaulttargetdir}/manifest.mf" excludes="**/package.html">
++ manifest="${defaulttargetdir}/MANIFEST.MF" excludes="**/package.html">
+ </jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
diff --git a/dev-java/commons-configuration/metadata.xml b/dev-java/commons-configuration/metadata.xml
new file mode 100644
index 000000000000..8f76559d3618
--- /dev/null
+++ b/dev-java/commons-configuration/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ Commons Configuration provides a generic configuration interface
+ which enables an application to read configuration data from
+ a variety of sources.
+ </longdescription>
+</pkgmetadata>