summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/cdi-api
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/cdi-api')
-rw-r--r--dev-java/cdi-api/Manifest1
-rw-r--r--dev-java/cdi-api/cdi-api-1.2.ebuild36
-rw-r--r--dev-java/cdi-api/metadata.xml5
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/cdi-api/Manifest b/dev-java/cdi-api/Manifest
new file mode 100644
index 000000000000..9a77655db8fa
--- /dev/null
+++ b/dev-java/cdi-api/Manifest
@@ -0,0 +1 @@
+DIST cdi-api-1.2-sources.jar 139331 SHA256 110dd88693b1745812a3f1c05f78d91aae1efa3cece5a08a5befd9dada51ed8c SHA512 b24a16cc208cd865f561ecdc7590ddcdb08c2e83f8fea75eefa0e52598461cc98c804dfeeacb360278ddfbf5508e72f381b1379e19efe91f3c89b0e255b3cb9a WHIRLPOOL abbf8754528ad7ffe505ae6f25d4920843c2d9bd4c03f7f4424aef35863d8780e6acd7c38e0dc65bad633b8e3f2ec289ba22e417381c1cef90a578a72dd07ef9
diff --git a/dev-java/cdi-api/cdi-api-1.2.ebuild b/dev-java/cdi-api/cdi-api-1.2.ebuild
new file mode 100644
index 000000000000..27f363be44f8
--- /dev/null
+++ b/dev-java/cdi-api/cdi-api-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Contexts and Dependency Injection for the Java EE platform"
+HOMEPAGE="http://www.cdi-spec.org/"
+SRC_URI="https://repo1.maven.org/maven2/javax/enterprise/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="1.2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/javax-inject:0
+ dev-java/glassfish-interceptor-api:0
+ dev-java/tomcat-servlet-api:3.0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+
+JAVA_SRC_DIR="src"
+
+JAVA_GENTOO_CLASSPATH="javax-inject,tomcat-servlet-api-3.0,glassfish-interceptor-api"
+
+java_prepare() {
+ mkdir src || die
+ mv * src
+}
diff --git a/dev-java/cdi-api/metadata.xml b/dev-java/cdi-api/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/cdi-api/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>