summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:09 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:29 +0100
commit6188355cf0af19cb96fbab3f3cb8aaacf200af47 (patch)
treedbaffbb3090f1f5d94cfdd7f81d2067a7091c49f /dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild
parentdev-haskell/xml-hamlet: add 0.5.0.2 (diff)
downloadgentoo-6188355cf0af19cb96fbab3f3cb8aaacf200af47.tar.gz
gentoo-6188355cf0af19cb96fbab3f3cb8aaacf200af47.tar.bz2
gentoo-6188355cf0af19cb96fbab3f3cb8aaacf200af47.zip
dev-haskell/xss-sanitize: add 0.3.7.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild')
-rw-r--r--dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild b/dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild
new file mode 100644
index 000000000000..b099d090cb66
--- /dev/null
+++ b/dev-haskell/xss-sanitize/xss-sanitize-0.3.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
+HOMEPAGE="https://github.com/yesodweb/haskell-xss-sanitize#readme"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
+ >=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ >=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/hunit-1.2
+ )
+"