summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-05 23:02:05 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:36 +0100
commit4b7a7abf9d433bcbfff8131611c82ec9e4cb2cd8 (patch)
tree72108600242b7d6881e2b136c322b35d5bfd8fa9 /dev-haskell/ghc-paths
parentdev-haskell/ghc-paths: add 0.1.0.12-r3 (diff)
downloadgentoo-4b7a7abf9d433bcbfff8131611c82ec9e4cb2cd8.tar.gz
gentoo-4b7a7abf9d433bcbfff8131611c82ec9e4cb2cd8.tar.bz2
gentoo-4b7a7abf9d433bcbfff8131611c82ec9e4cb2cd8.zip
dev-haskell/ghc-paths: Migrate to CABAL_CHDEPS
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/ghc-paths')
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
index 6a8cad7ee4d5..576d465f38c5 100644
--- a/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.12-r1.ebuild
@@ -24,16 +24,17 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6 <dev-haskell/cabal-3.7
"
+# https://github.com/simonmar/ghc-paths/pull/26
+CABAL_CHDEPS=(
+ 'Cabal >= 1.6 && <3.1' 'Cabal >= 1.6 && <3.7'
+)
+
src_prepare() {
- default
+ haskell-cabal_src_prepare
# ghc-patch it has awfully unportable (across cabal versions) ghc detection code
# but in gentoo we install it to fixed patch, so remove Setup.hs detection code
cabal-mksetup
- # https://github.com/simonmar/ghc-paths/pull/26
- cabal_chdeps \
- 'Cabal >= 1.6 && <3.1' 'Cabal >= 1.6 && <3.7'
-
# and use gentoo's hardcoded one:
# a few things we need to replace, and example values
# GHC_PATHS_LIBDIR /usr/lib64/ghc-6.12.0.20091010