summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/concurrent-extra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/concurrent-extra')
-rw-r--r--dev-haskell/concurrent-extra/Manifest3
-rw-r--r--dev-haskell/concurrent-extra/concurrent-extra-0.7.0.6.ebuild35
-rw-r--r--dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild33
-rw-r--r--dev-haskell/concurrent-extra/concurrent-extra-0.7.0.9.ebuild32
-rw-r--r--dev-haskell/concurrent-extra/metadata.xml35
5 files changed, 138 insertions, 0 deletions
diff --git a/dev-haskell/concurrent-extra/Manifest b/dev-haskell/concurrent-extra/Manifest
new file mode 100644
index 000000000000..684026914f30
--- /dev/null
+++ b/dev-haskell/concurrent-extra/Manifest
@@ -0,0 +1,3 @@
+DIST concurrent-extra-0.7.0.6.tar.gz 16447 SHA256 11a1b241b6be6502af86b30a060218fb6776d636dc11399bc742f837a141988b SHA512 77e01122b4659cb131af596da6b4638d34365f3be901b46adb1e7ffcb9d218727feead51b107df0418e1f929eced5aea0ce412ff59ffae3bb6b5d50215b277cf WHIRLPOOL d3f28b42dc115b5607b02b9235b8ec4221e59734a9cb6981fbd1fd662c72d70776df9e2cf4a533c373eeaa11b446c8c3e0111ede89ba6f241f9b056f13088016
+DIST concurrent-extra-0.7.0.8.tar.gz 16646 SHA256 78203bfb522583ebdc2ea6c8708049b83710935dbdfe916576dbeea9283fd660 SHA512 f34a7dddfdd282c72449ff53394977a118bb24b58c84d6e784f117037bce0d36c8fffd790abcece0976e0d29a8613fa85163ce2b740909aadf7afe04ce8fe734 WHIRLPOOL fe6689127705b77db2ad86ff4b85924890c3192743f74a5ac59ad6f0f5d71360fd45eb9d18b0c955af3994e7826b72922ac4fc4d37ac5b883b60f09917f15f76
+DIST concurrent-extra-0.7.0.9.tar.gz 16209 SHA256 5c8535c5155c747fdc04fcf731da3ccad6236e49295e6fcbad102e9b17a878a5 SHA512 2ccdb2ceaffed411b6e8b1723ff4c0d489425a83b9237b7397553e78bea6702cf2bf8b7d96d24c285337a8768b0859a7c45442cb55f3a3f59d4ecba228bead72 WHIRLPOOL f83640847825f779dafbe2459a6291e849f440d90b62437f43ccb105faf6af877b0b5ae7e02dd9007697c2d48a638b28c008ac08ff10f3047cbe76e53aae872b
diff --git a/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.6.ebuild b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.6.ebuild
new file mode 100644
index 000000000000..14639f91763f
--- /dev/null
+++ b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extra concurrency primitives"
+HOMEPAGE="https://github.com/basvandijk/concurrent-extra"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-unicode-symbols-0.1.1:=[profile?]
+ <dev-haskell/base-unicode-symbols-0.3:=[profile?]
+ >=dev-haskell/stm-2.1.2.1:=[profile?]
+ <dev-haskell/stm-2.5:=[profile?]
+ =dev-haskell/unbounded-delays-0.1*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2.2
+ <dev-haskell/hunit-1.3
+ >=dev-haskell/test-framework-0.2.4
+ <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.4
+ <dev-haskell/test-framework-hunit-0.4
+ )"
diff --git a/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild
new file mode 100644
index 000000000000..b71c3d759edd
--- /dev/null
+++ b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile test-suite" # haddock fails for strange reason
+inherit haskell-cabal
+
+DESCRIPTION="Extra concurrency primitives"
+HOMEPAGE="https://github.com/basvandijk/concurrent-extra"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-unicode-symbols-0.1.1:=[profile?] <dev-haskell/base-unicode-symbols-0.3:=[profile?]
+ >=dev-haskell/stm-2.1.2.1:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?] <dev-haskell/unbounded-delays-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/async-2.0 <dev-haskell/async-2.1
+ >=dev-haskell/hunit-1.2.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.1
+ >=dev-haskell/test-framework-0.2.4 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.4 <dev-haskell/test-framework-hunit-0.4 )
+"
diff --git a/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.9.ebuild b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.9.ebuild
new file mode 100644
index 000000000000..b316d44810f5
--- /dev/null
+++ b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extra concurrency primitives"
+HOMEPAGE="https://github.com/basvandijk/concurrent-extra"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.1.2.1:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?] <dev-haskell/unbounded-delays-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/async-2.0 <dev-haskell/async-2.1
+ >=dev-haskell/hunit-1.2.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.2
+ >=dev-haskell/test-framework-0.2.4 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.4 <dev-haskell/test-framework-hunit-0.4 )
+"
diff --git a/dev-haskell/concurrent-extra/metadata.xml b/dev-haskell/concurrent-extra/metadata.xml
new file mode 100644
index 000000000000..df4f0da831a9
--- /dev/null
+++ b/dev-haskell/concurrent-extra/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The @concurrent-extra@ package offers among other things the
+ following selection of synchronisation primitives:
+
+ * @Broadcast@: Wake multiple threads by broadcasting a value.
+
+ * @Event@: Wake multiple threads by signalling an event.
+
+ * @Lock@: Enforce exclusive access to a resource. Also known as a
+ binary semaphore or mutex. The package additionally provides an
+ alternative that works in the @STM@ monad.
+
+ * @RLock@: A lock which can be acquired multiple times by the same
+ thread. Also known as a reentrant mutex.
+
+ * @ReadWriteLock@: Multiple-reader, single-writer locks. Used to
+ protect shared resources which may be concurrently read, but only
+ sequentially written.
+
+ * @ReadWriteVar@: Concurrent read, sequential write variables.
+
+ Please consult the API documentation of the individual modules for
+ more detailed information.
+
+ This package was inspired by the concurrency libraries of Java and
+ Python.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">basvandijk/concurrent-extra</remote-id>
+ </upstream>
+</pkgmetadata>