summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-23 21:37:03 +0100
committerSam James <sam@gentoo.org>2022-07-23 21:55:31 +0100
commitf04066a15b80953ea295a4f019355676a6dc33c0 (patch)
treebf8e48decec189d810f223f9ee43b52c3f9d8d92 /dev-haskell/atomic-primops
parentgui-wm/sway: EAPI bump, minor improvements (diff)
downloadgentoo-f04066a15b80953ea295a4f019355676a6dc33c0.tar.gz
gentoo-f04066a15b80953ea295a4f019355676a6dc33c0.tar.bz2
gentoo-f04066a15b80953ea295a4f019355676a6dc33c0.zip
dev-haskell/atomic-primops: add 0.8.4 (sync w/ ::haskell)
Closes: https://bugs.gentoo.org/860261 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/atomic-primops')
-rw-r--r--dev-haskell/atomic-primops/Manifest1
-rw-r--r--dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild30
-rw-r--r--dev-haskell/atomic-primops/metadata.xml16
3 files changed, 41 insertions, 6 deletions
diff --git a/dev-haskell/atomic-primops/Manifest b/dev-haskell/atomic-primops/Manifest
index 58a9046fbf9f..a93b226a6311 100644
--- a/dev-haskell/atomic-primops/Manifest
+++ b/dev-haskell/atomic-primops/Manifest
@@ -1 +1,2 @@
DIST atomic-primops-0.8.3.tar.gz 34880 BLAKE2B 44bda52c0e6f52fe6663f70b4f55b630fe89bb12e41f50134b54f51524a9f839aacf65e658cba72f8071a188db7b6b09ab81ccfaf95354d52dfe2a5b39befff6 SHA512 c92371741ea6e0a0208d539abea73c53269b155f3dc84ebea7b20afab5882852756a0c15fdc309c9a9d6ad575589d8f8a99adb9117bbe3d7465d97b17af08b09
+DIST atomic-primops-0.8.4.tar.gz 33639 BLAKE2B 5293b6f839599fe7a47c8f3f13a03df12fe8a5d7223a4b488a86b7f1f2c208ecd01f75acf7378668b4f91046221d9076875e05ca2611bb51d6ff1ad7a2e0d8f6 SHA512 a9e873e6f4eba26541d370c5ee3b81b518a1bf0f54d303d26a2065ba47eac7db1366436661b108c0648503386ffb9cb121567236c9635bf30d4e523a2d63a8b4
diff --git a/dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild b/dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild
new file mode 100644
index 000000000000..5222fa5a40cd
--- /dev/null
+++ b/dev-haskell/atomic-primops/atomic-primops-0.8.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A safe approach to CAS and other atomic ops in Haskell"
+HOMEPAGE="https://github.com/rrnewton/haskell-lockfree/wiki"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-haskell/primitive:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}
diff --git a/dev-haskell/atomic-primops/metadata.xml b/dev-haskell/atomic-primops/metadata.xml
index 6bed7c28c7bf..29001c3441a1 100644
--- a/dev-haskell/atomic-primops/metadata.xml
+++ b/dev-haskell/atomic-primops/metadata.xml
@@ -5,17 +5,21 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <use>
+ <flag name="debug">Enable extra internal checks.</flag>
+ </use>
<longdescription>
- After GHC 7.4 a new `casMutVar#` primop became available, but it's
+ After GHC 7.4 a new `casMutVar#` primop became available, but it&#39;s
difficult to use safely, because pointer equality is a highly
unstable property in Haskell. This library provides a safer method
- based on the concept of "Tickets".
+ based on the concept of &quot;Tickets&quot;.
- Also, this library uses the "foreign primop" capability of GHC to
+ Also, this library uses the &quot;foreign primop&quot; capability of GHC to
add access to other variants that may be of
interest, specifically, compare and swap inside an array.
+
+ Note that as of GHC 7.8, the relevant primops have been included in GHC itself.
+ This library is engineered to work pre- and post-GHC-7.8, while exposing the
+ same interface.
</longdescription>
- <upstream>
- <remote-id type="github">rrnewton/haskell-lockfree</remote-id>
- </upstream>
</pkgmetadata>