summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:07:34 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:22:00 +0000
commit767e4b8a94347f97a288804c4c8d804c56eaa2f2 (patch)
treec8eb73f8221c1232171e8d5e13a08a4b6b48bb77 /dev-haskell/async/async-2.1.1.ebuild
parentdev-haskell/memory: bump up to 0.14.1 (diff)
downloadgentoo-767e4b8a94347f97a288804c4c8d804c56eaa2f2.tar.gz
gentoo-767e4b8a94347f97a288804c4c8d804c56eaa2f2.tar.bz2
gentoo-767e4b8a94347f97a288804c4c8d804c56eaa2f2.zip
dev-haskell/async: bump up to 2.1.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/async/async-2.1.1.ebuild')
-rw-r--r--dev-haskell/async/async-2.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/async/async-2.1.1.ebuild b/dev-haskell/async/async-2.1.1.ebuild
new file mode 100644
index 000000000000..8d3e4d371720
--- /dev/null
+++ b/dev-haskell/async/async-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"