summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-01-16 15:42:33 -0800
committerZac Medico <zmedico@gentoo.org>2019-01-16 15:45:28 -0800
commitf6062324fafc45ef5b5a80bfb3ee1ea1b687522c (patch)
tree2c003632be47bfaf7e14118b44693d8c24d031d4 /dev-go/go-bindata-assetfs/go-bindata-assetfs-1.0.0_p20180223.ebuild
parentnet-libs/zeromq: stable 4.3.1 for ia64, bug #675376 (diff)
downloadgentoo-f6062324fafc45ef5b5a80bfb3ee1ea1b687522c.tar.gz
gentoo-f6062324fafc45ef5b5a80bfb3ee1ea1b687522c.tar.bz2
gentoo-f6062324fafc45ef5b5a80bfb3ee1ea1b687522c.zip
dev-go/go-bindata-assetfs: version bump to 1.0.0_p20180223
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-go/go-bindata-assetfs/go-bindata-assetfs-1.0.0_p20180223.ebuild')
-rw-r--r--dev-go/go-bindata-assetfs/go-bindata-assetfs-1.0.0_p20180223.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/go-bindata-assetfs/go-bindata-assetfs-1.0.0_p20180223.ebuild b/dev-go/go-bindata-assetfs/go-bindata-assetfs-1.0.0_p20180223.ebuild
new file mode 100644
index 000000000000..319c6f69c0bc
--- /dev/null
+++ b/dev-go/go-bindata-assetfs/go-bindata-assetfs-1.0.0_p20180223.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/elazarl/go-bindata-assetfs/..."
+EGIT_COMMIT="38087fe4dafb822e541b3f7955075cc1c30bd294"
+ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Serve embedded files from jteeuwen/go-bindata with net/http"
+HOMEPAGE="https://github.com/elazarl/go-bindata-assetfs"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+
+RDEPEND="dev-go/go-bindata"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/*
+}