summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-07-26 21:17:10 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-07-26 21:22:59 +0100
commit9c299edf72abf376f1de889939f8eac4284a634d (patch)
tree928ac0c93f2e60f4a236baadd5db99d3e0cc9619 /dev-games/flatzebra/flatzebra-0.1.7.ebuild
parentdev-games/flatzebra: EAPI7, fix LICENSE, cleanup (diff)
downloadgentoo-9c299edf72abf376f1de889939f8eac4284a634d.tar.gz
gentoo-9c299edf72abf376f1de889939f8eac4284a634d.tar.bz2
gentoo-9c299edf72abf376f1de889939f8eac4284a634d.zip
dev-games/flatzebra: Bump to 0.1.7
HTTPS dropped due to expired certificate. Unlike 0.1.6, this version builds with clang. Bug: https://bugs.gentoo.org/729736 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-games/flatzebra/flatzebra-0.1.7.ebuild')
-rw-r--r--dev-games/flatzebra/flatzebra-0.1.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-games/flatzebra/flatzebra-0.1.7.ebuild b/dev-games/flatzebra/flatzebra-0.1.7.ebuild
new file mode 100644
index 000000000000..725e4ddcf45f
--- /dev/null
+++ b/dev-games/flatzebra/flatzebra-0.1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Generic game engine for 2D double-buffering animation"
+HOMEPAGE="http://perso.b2b2c.ca/~sarrazip/dev/batrachians.html"
+SRC_URI="http://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^doc_DATA =/s/^/NOTHANKS/' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}