summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:56:14 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:56:14 +0100
commit67071be387ad62b948ac5f48d883ca3f7b0239c6 (patch)
tree900ef0f1b8828128ecf3acdcd08da67dcecac434 /dev-db/postgresql/postgresql-11.11.ebuild
parentdev-db/etcd: migrate to tmpfiles.eclass (diff)
downloadgentoo-67071be387ad62b948ac5f48d883ca3f7b0239c6.tar.gz
gentoo-67071be387ad62b948ac5f48d883ca3f7b0239c6.tar.bz2
gentoo-67071be387ad62b948ac5f48d883ca3f7b0239c6.zip
dev-db/postgresql: migrate to tmpfiles.eclass
Closes: https://bugs.gentoo.org/740592 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/postgresql/postgresql-11.11.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-11.11.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-db/postgresql/postgresql-11.11.ebuild b/dev-db/postgresql/postgresql-11.11.ebuild
index cf5cd351c515..76d8f0069f89 100644
--- a/dev-db/postgresql/postgresql-11.11.ebuild
+++ b/dev-db/postgresql/postgresql-11.11.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd
+inherit flag-o-matic linux-info multilib pam prefix python-single-r1 systemd tmpfiles
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -256,7 +256,7 @@ src_install() {
"${FILESDIR}/${PN}.service-9.6-r1" | \
systemd_newunit - ${PN}-${SLOT}.service
newbin "${FILESDIR}"/${PN}-check-db-dir ${PN}-${SLOT}-check-db-dir
- systemd_newtmpfilesd "${FILESDIR}"/${PN}.tmpfiles ${PN}-${SLOT}.conf
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}-${SLOT}.conf
fi
use pam && pamd_mimic system-auth ${PN}-${SLOT} auth account session
@@ -269,7 +269,7 @@ src_install() {
}
pkg_postinst() {
- use server && use systemd && systemd_tmpfiles_create ${PN}-${SLOT}.conf
+ use server && use systemd && tmpfiles_process ${PN}-${SLOT}.conf
postgresql-config update
elog "If you need a global psqlrc-file, you can place it in:"