summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-09-21 15:39:54 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-09-21 15:39:54 +0200
commit8f7e6fac8e9721761d7e7c73450028f54a8c2be1 (patch)
treebba3a678d6b4aa76faa082b5c0c5b23b758fb3b1 /dev-db/pg_activity/pg_activity-3.0.0.ebuild
parentapp-editors/gnome-text-editor: Version bump to 43.0 (diff)
downloadgentoo-8f7e6fac8e9721761d7e7c73450028f54a8c2be1.tar.gz
gentoo-8f7e6fac8e9721761d7e7c73450028f54a8c2be1.tar.bz2
gentoo-8f7e6fac8e9721761d7e7c73450028f54a8c2be1.zip
dev-db/pg_activity: version bump to 3.0.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db/pg_activity/pg_activity-3.0.0.ebuild')
-rw-r--r--dev-db/pg_activity/pg_activity-3.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-db/pg_activity/pg_activity-3.0.0.ebuild b/dev-db/pg_activity/pg_activity-3.0.0.ebuild
new file mode 100644
index 000000000000..6389027fa3a9
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:0[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}