summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-03-11 17:30:10 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-03-11 19:25:22 +0100
commitd1a22fa531c41c3b0d5f8c99437ec52bc19c96ac (patch)
tree57f4623ff6f2d1dfbeb047fb846ae426314919e6 /dev-db/mysql-connector-c
parentnet-analyzer/nmap: revert 7.91-r2 keywords (diff)
downloadgentoo-d1a22fa531c41c3b0d5f8c99437ec52bc19c96ac.tar.gz
gentoo-d1a22fa531c41c3b0d5f8c99437ec52bc19c96ac.tar.bz2
gentoo-d1a22fa531c41c3b0d5f8c99437ec52bc19c96ac.zip
dev-db/mysql-connector-c: disable debug options
Previous version used now deprecated cmake-utils eclass which added -DNDEBUG to CPP flags. With new cmake eclass we have to do that on our own. Let us do it the same way we do it for dev-db/mysql, i.e. set CMAKE_BUILD_TYPE and corresponding CMAKE_CXX_FLAGS_RELWITHDEBINFO option. Closes: https://bugs.gentoo.org/775047 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/mysql-connector-c')
-rw-r--r--dev-db/mysql-connector-c/mysql-connector-c-8.0.23-r1.ebuild (renamed from dev-db/mysql-connector-c/mysql-connector-c-8.0.23.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-db/mysql-connector-c/mysql-connector-c-8.0.23.ebuild b/dev-db/mysql-connector-c/mysql-connector-c-8.0.23-r1.ebuild
index 6553c3776e50..ccb3b8c270bd 100644
--- a/dev-db/mysql-connector-c/mysql-connector-c-8.0.23.ebuild
+++ b/dev-db/mysql-connector-c/mysql-connector-c-8.0.23-r1.ebuild
@@ -77,7 +77,11 @@ src_prepare() {
}
multilib_src_configure() {
+ CMAKE_BUILD_TYPE="RelWithDebInfo"
+
local mycmakeargs=(
+ -DCMAKE_C_FLAGS_RELWITHDEBINFO=-DNDEBUG
+ -DCMAKE_CXX_FLAGS_RELWITHDEBINFO=-DNDEBUG
-DINSTALL_LAYOUT=RPM
-DINSTALL_LIBDIR=$(get_libdir)
-DWITH_DEFAULT_COMPILER_OPTIONS=OFF
@@ -93,6 +97,7 @@ multilib_src_configure() {
-DCMAKE_POSITION_INDEPENDENT_CODE=ON
-DWITHOUT_SERVER=ON
)
+
cmake_src_configure
}