summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/lib_mysqludf_preg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/lib_mysqludf_preg')
-rw-r--r--dev-db/lib_mysqludf_preg/Manifest1
-rw-r--r--dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild59
-rw-r--r--dev-db/lib_mysqludf_preg/metadata.xml7
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_preg/Manifest b/dev-db/lib_mysqludf_preg/Manifest
new file mode 100644
index 000000000000..2e1f9807b4f2
--- /dev/null
+++ b/dev-db/lib_mysqludf_preg/Manifest
@@ -0,0 +1 @@
+DIST lib_mysqludf_preg-1.0.1.tar.gz 321868 SHA256 50c7179b354148d66a2324f1a8ed918b133924c8fc0cd53c28afda70e1768daa SHA512 36bb9c412d5f69040e5d4b3325a4b95e5e165010daea240c96611135b2c74dddb3e36bb6938c0684ecc30ff08151ce7543167a9e3a05e3e5cd0361102b1b083d WHIRLPOOL 72a0ff7ad9a9e0ff5e1beac108fcbbe8d312268740eb4341eecd4f2eacdbab1bd2fcb20f9770bcbdfe6a6d7d183b11be35cb9ea15f876551c7b0365d48da3812
diff --git a/dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild b/dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild
new file mode 100644
index 000000000000..88d9d1d7bad6
--- /dev/null
+++ b/dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="MySQL UDFs that provide access to the PCRE library for pattern matching"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_preg/"
+SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1
+ dev-libs/libpcre"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ edos2unix README
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
+}
+
+src_install() {
+ local X
+ emake DESTDIR="${D}" install
+ [ -f ${PN}.html ] && dohtml ${PN}.html
+ [ -d doc/html ] && dohtml -r doc/html/.
+ for X in API AUTHORS ChangeLog NEWS README *installdb.sql; do
+ [ -s "${X}" ] && dodoc "${X}"
+ done
+
+ # remove obsolete *.la file
+ rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_preg/metadata.xml b/dev-db/lib_mysqludf_preg/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-db/lib_mysqludf_preg/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>