summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-06 07:20:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-06 07:35:20 +0100
commit128b8857a5c42248ec09f4535c5e63f3ada2e2df (patch)
tree4fe06fd968bea2211cb7439239c7539127b49757 /dev-cpp
parentdev-python/python-docs: Remove old (diff)
downloadgentoo-128b8857a5c42248ec09f4535c5e63f3ada2e2df.tar.gz
gentoo-128b8857a5c42248ec09f4535c5e63f3ada2e2df.tar.bz2
gentoo-128b8857a5c42248ec09f4535c5e63f3ada2e2df.zip
dev-cpp/rapidfuzz-cpp: Bump to 1.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/rapidfuzz-cpp/Manifest1
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.10.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-cpp/rapidfuzz-cpp/Manifest b/dev-cpp/rapidfuzz-cpp/Manifest
index f8eaf0948ac1..484fbef27159 100644
--- a/dev-cpp/rapidfuzz-cpp/Manifest
+++ b/dev-cpp/rapidfuzz-cpp/Manifest
@@ -1,2 +1,3 @@
DIST rapidfuzz-cpp-1.10.0.gh.tar.gz 283171 BLAKE2B d126134f3250b5c5320d5776bb913b6458f5bcc61629c1ffd5957b3ddf79e5ff1ccc1c67a9c33271942e7f59846c73d2fdc672a99141964dae716c4ac8057193 SHA512 5d9b184e2b7975b0ba3f29e2698b80906afffa7c561f8b7c49988f99c92ff480bf0a471cb48f7e8024f3e048fb2b01ebbbf1bc28afacee78890f6a595cf10517
+DIST rapidfuzz-cpp-1.10.1.gh.tar.gz 284749 BLAKE2B 530476df0120e0a864298f80d786df02e0bc77a9b3482b2be7ff94ed4c4c749828eddadcaae2e8958e991744842380c48e2ce1bfa59062dc592b6a8905dbc234 SHA512 9e33601b85189bca8ff1ff21e33f62fb674d6f6ce5713588f303b5879b02eba84e96421fea3c96cfc6a7393ad5a95c755176d7c17e7f4c81498516f163584bf6
DIST rapidfuzz-cpp-1.9.0.gh.tar.gz 281385 BLAKE2B 4afc48edd9c8270200645eb77065bf212b9579b90b3916e261bbe69fd60f67c1e510c3ae4ef9877a26c3313063717b362e01c6cf799a0f9fc3429799d9b2dca6 SHA512 d95c90f9118811d650d859a20f847c71427acbc8c4f907f49d23b069cd6d1a848749d32f8fbff7326828b7a030c3f488acacba5845a72a0057ccf4c3088badf4
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.10.1.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.10.1.ebuild
new file mode 100644
index 000000000000..32f8979b752f
--- /dev/null
+++ b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Rapid fuzzy string matching in C++"
+HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
+SRC_URI="
+ https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ >=dev-cpp/catch-3
+ )
+"
+
+src_prepare() {
+ # apparently "C++ best practices" don't mind fetching random stuff
+ # at build time
+ sed -i -e '/aminya/,/^)/d' test/CMakeLists.txt || die
+ find -name 'CMakeLists.txt' -exec \
+ sed -i -e 's:project_warnings::' {} + || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}