summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Fischl <github@fischl-online.de>2023-04-20 06:56:48 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-05-07 10:22:52 +0300
commit4bb836108f2c4e08a8134405412366ad3ecd4a4f (patch)
treef13a6ed4559b67f174e0cd3d3c8556c2206106fc /app-text
parentmedia-gfx/aaphoto: bump snapshot to 0.45_p20160710 (diff)
downloadgentoo-4bb836108f2c4e08a8134405412366ad3ecd4a4f.tar.gz
gentoo-4bb836108f2c4e08a8134405412366ad3ecd4a4f.tar.bz2
gentoo-4bb836108f2c4e08a8134405412366ad3ecd4a4f.zip
app-text/xlsx2csv: bump 0.8.1
Signed-off-by: Anton Fischl <github@fischl-online.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xlsx2csv/Manifest1
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.8.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/xlsx2csv/Manifest b/app-text/xlsx2csv/Manifest
index d4c75dbb6f6c..3d58d5650340 100644
--- a/app-text/xlsx2csv/Manifest
+++ b/app-text/xlsx2csv/Manifest
@@ -1,2 +1,3 @@
DIST xlsx2csv-0.7.6.tar.gz 231283 BLAKE2B d0271c6a82b7ed2825e3224f0e34637db3dacda3fe99c6ef5a087cc8d248592efc169b466514abd18b50f6625e8d9743c812b46ecb6f76ce7d1fdc51dfe34fc4 SHA512 7fc8e0da0c050e12d0cfd73f16ffd9c00f19bf05925b54cc68d6a0858a75db89d52e46312956dfd149e0ec88778f68056942a090db44e6148796fad33fa26489
DIST xlsx2csv-0.8.0.tar.gz 208842 BLAKE2B bfe69c39a8312feec35bb9a8079982f0765cbe975ce9d842ccd969d1399d03202ddf8d41c54f5129d122f535272add38c1489c0804340cc24bf1091779d76a2c SHA512 dd9ced043f347d420371aaf68f65b1ae827f231ceddbfb051174c8072dda27f989490120d0ee6bbe1fb25faf79944242144e196ccf58db5c537d5b0826cb91ee
+DIST xlsx2csv-0.8.1.tar.gz 215741 BLAKE2B 0fcfe8177bc9d50d0986bea45373be8efb80753a53054bb254ab6fa93a4f4e038d1b7b991f1fb3850e9cd928f4aacfc3b0a927edbaacd77065eb6dc8067cc227 SHA512 0d091a3912a3c0a10837acb2bf1a4c42478a891b0c9cfaceb74a8e511425c63360f24cb08db138ec51a7c189f0b76f3901789edb45f894ab8926dd4c458c7ff5
diff --git a/app-text/xlsx2csv/xlsx2csv-0.8.1.ebuild b/app-text/xlsx2csv/xlsx2csv-0.8.1.ebuild
new file mode 100644
index 000000000000..acc1f01a79f3
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=( "${FILESDIR}"/"${PN}-0.7.8-tests.patch" )
+
+python_compile_all() {
+ emake -C man
+}
+
+python_test() {
+ "${EPYTHON}" test/run || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman "man/${PN}.1"
+}