summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-15 22:29:27 -0400
committerZac Medico <zmedico@gentoo.org>2023-10-17 21:26:02 -0700
commit080103195a8b542af4d54890797857b7008a1123 (patch)
treeefe5d8b127250cdebbed113df5ab129cbba1ce0d /app-text
parentapp-text/calibre: trivial refactor of skippable tests (diff)
downloadgentoo-080103195a8b542af4d54890797857b7008a1123.tar.gz
gentoo-080103195a8b542af4d54890797857b7008a1123.tar.bz2
gentoo-080103195a8b542af4d54890797857b7008a1123.zip
app-text/calibre: misc cleanup
guard a command that cannot die with `|| die` for style reasons. Drop a commented-out bit of code that is no longer relevant. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/calibre-5.44.0-r2.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/app-text/calibre/calibre-5.44.0-r2.ebuild b/app-text/calibre/calibre-5.44.0-r2.ebuild
index b90a58692d78..8a63bfb638e5 100644
--- a/app-text/calibre/calibre-5.44.0-r2.ebuild
+++ b/app-text/calibre/calibre-5.44.0-r2.ebuild
@@ -156,11 +156,6 @@ src_prepare() {
#
# If in doubt about a problem, checking Fedora's packaging is recommended.
- # Fix outdated version constant.
- #sed -e "s#\\(^numeric_version =\\).*#\\1 (${PV//./, })#" \
- # -i src/calibre/constants.py || \
- # die "sed failed to patch constants.py"
-
# Disable unnecessary privilege dropping for bug #287067.
sed -e "s:if os.geteuid() == 0:if False and os.geteuid() == 0:" \
-i setup/install.py || die "sed failed to patch install.py"
@@ -238,7 +233,7 @@ src_install() {
--libdir="${EPREFIX}/usr/$(get_libdir)" \
--staging-libdir="${ED}/usr/$(get_libdir)" || die
- find "${ED}"/usr/share -type d -empty -delete
+ find "${ED}"/usr/share -type d -empty -delete || die
einfo "Converting python shebangs"
python_fix_shebang "${ED}/usr/bin"