summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 07:05:22 +0100
committerSam James <sam@gentoo.org>2023-04-15 07:05:22 +0100
commit01eecce52925970412864da41cb38c10fadfdba7 (patch)
treeea00acf5389bedd7cd7b8e6da710e268955ca6fa /app-text
parentapp-arch/engrampa: fix build w/ clang 16 (diff)
downloadgentoo-01eecce52925970412864da41cb38c10fadfdba7.tar.gz
gentoo-01eecce52925970412864da41cb38c10fadfdba7.tar.bz2
gentoo-01eecce52925970412864da41cb38c10fadfdba7.zip
app-text/ttf2pt1: fix build w/ clang 16
This does not fix the pointer types issues though. Closes: https://bugs.gentoo.org/881321 Bug: https://bugs.gentoo.org/883205 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ttf2pt1/files/ttf2pt1-3.4.4-clang16.patch61
-rw-r--r--app-text/ttf2pt1/ttf2pt1-3.4.4-r2.ebuild (renamed from app-text/ttf2pt1/ttf2pt1-3.4.4-r1.ebuild)5
2 files changed, 64 insertions, 2 deletions
diff --git a/app-text/ttf2pt1/files/ttf2pt1-3.4.4-clang16.patch b/app-text/ttf2pt1/files/ttf2pt1-3.4.4-clang16.patch
new file mode 100644
index 000000000000..cb54195872e9
--- /dev/null
+++ b/app-text/ttf2pt1/files/ttf2pt1-3.4.4-clang16.patch
@@ -0,0 +1,61 @@
+https://sourceforge.net/p/ttf2pt1/mailman/message/37804025/
+https://bugs.gentoo.org/881321
+
+Avoid implicit ints and implicit function declarations, and build
+failures with future compilers which do not support this pre-C99
+features by default.
+
+--- a/other/bmpfont.h
++++ b/other/bmpfont.h
+@@ -2,7 +2,9 @@
+ * see COPYRIGHT
+ */
+
++#include <stdlib.h>
+
++void
+ fchkneg(file, line, rc, cmd)
+ char *file;
+ int line;
+@@ -17,6 +19,7 @@ fchkneg(file, line, rc, cmd)
+ }
+ }
+
++void
+ fchknull(file, line, rc, cmd)
+ char *file;
+ int line;
+--- a/other/cmpf.c
++++ b/other/cmpf.c
+@@ -14,7 +14,7 @@
+
+ #include "bmpfont.h"
+
+-
++int
+ main(ac, av)
+ int ac;
+ char **av;
+--- a/other/dmpf.c
++++ b/other/dmpf.c
+@@ -14,7 +14,7 @@
+
+ #include "bmpfont.h"
+
+-
++int
+ main(ac, av)
+ int ac;
+ char **av;
+--- a/t1asm.c
++++ b/t1asm.c
+@@ -59,6 +59,8 @@ static char portnotice[] =
+ # define WINDOWS_FUNCTIONS
+ # include "windows.h"
+ # endif
++#else
++# include <unistd.h>
+ #endif
+
+ /* int32 must be at least 32-bit and uint16 must be at least 16-bit */
+
diff --git a/app-text/ttf2pt1/ttf2pt1-3.4.4-r1.ebuild b/app-text/ttf2pt1/ttf2pt1-3.4.4-r2.ebuild
index fcc8361c32a0..f108cacf8cc0 100644
--- a/app-text/ttf2pt1/ttf2pt1-3.4.4-r1.ebuild
+++ b/app-text/ttf2pt1/ttf2pt1-3.4.4-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -22,6 +22,7 @@ PATCHES=(
"${FILESDIR}"/${P}-LDFLAGS.patch
"${FILESDIR}"/${PN}-3.4.0-man-pages.diff
"${FILESDIR}"/${P}-freetype.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {