summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2023-11-01 22:50:59 +0100
committerSam James <sam@gentoo.org>2024-01-20 12:02:32 +0000
commit72ffabd24a709e3a2dc7aaf1d7432aa278742a4c (patch)
tree507493634d89506c09ffdd28ae45efedce00b1a0 /app-text/mupdf
parentx11-wm/fvwm3: force prebuilt docs off for 9999 (diff)
downloadgentoo-72ffabd24a709e3a2dc7aaf1d7432aa278742a4c.tar.gz
gentoo-72ffabd24a709e3a2dc7aaf1d7432aa278742a4c.tar.bz2
gentoo-72ffabd24a709e3a2dc7aaf1d7432aa278742a4c.zip
app-text/mupdf: add 1.23.7
Add sed call to make pkgconfig file respect EPREFIX. Closes: https://bugs.gentoo.org/911965 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/33635 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/mupdf')
-rw-r--r--app-text/mupdf/Manifest1
-rw-r--r--app-text/mupdf/mupdf-1.23.7.ebuild165
2 files changed, 166 insertions, 0 deletions
diff --git a/app-text/mupdf/Manifest b/app-text/mupdf/Manifest
index 604d267216ce..a835f7c90abd 100644
--- a/app-text/mupdf/Manifest
+++ b/app-text/mupdf/Manifest
@@ -1,2 +1,3 @@
DIST mupdf-1.22.0-source.tar.gz 55043552 BLAKE2B 745a2fd1d0406acf4fa696585bcd21a4ff36e7539c1d45f886dfe5c9bbf966169e5183e89940d81e88db3014f1ebb0446ae1732b6c2fa25a135251853b71f1f7 SHA512 ba073b977306420343c969e6fec37cca4559031ad06cfdee2356edfdfa013ebe7654175aff931684fa48a935bf87f68537754b5e83f767517bc428ac07709a59
DIST mupdf-1.23.3-source.tar.gz 55144800 BLAKE2B 816e2bf46c2431df9726976efeaa0d7ebd8809cbdd9331a747cca32088aaf21b70e9522614d1dc20c856cc597003be6285f866eae8bbde3098e702acfdea8465 SHA512 37fbebd07680d79a38d289264a4028396ee58fad52c541efa37463e63a45ed8bab71188d6c05eb15e602964d89ee6633575dceb972f7bd8b0b5efdde5af9b737
+DIST mupdf-1.23.7-source.tar.gz 55312697 BLAKE2B 7ceb7c1871d33b77d4a3d52ed2d1af514c09349df019a189fa7df8ad09648fae313d63de4c1ce6b0666d17f9a897d5ac788d0be2d8896d9b7e4e6ecf679bad7c SHA512 581a4a5a16041bb405fbd7c1b9fba47da5745f00cbdf30e0e0468bfe67ac542884193b5957b293a4cdfc52f043b4f19612086f294b93dbd242d34735a1088777
diff --git a/app-text/mupdf/mupdf-1.23.7.ebuild b/app-text/mupdf/mupdf-1.23.7.ebuild
new file mode 100644
index 000000000000..ef850b89b6d9
--- /dev/null
+++ b/app-text/mupdf/mupdf-1.23.7.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please check upstream git regularly for relevant security-related commits
+# to backport.
+
+inherit desktop flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="A lightweight PDF viewer and toolkit written in portable C"
+HOMEPAGE="https://mupdf.com/ https://git.ghostscript.com/?p=mupdf.git"
+SRC_URI="https://mupdf.com/downloads/archive/${P}-source.tar.gz"
+S="${WORKDIR}"/${P}-source
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+javascript opengl ssl X"
+REQUIRED_USE="opengl? ( javascript )"
+
+# Although we use the bundled, patched version of freeglut in mupdf (because of
+# bug #653298), the best way to ensure that its dependencies are present is to
+# install system's freeglut.
+RDEPEND="
+ dev-libs/gumbo
+ media-libs/freetype:2
+ media-libs/harfbuzz:=[truetype]
+ media-libs/jbig2dec:=
+ media-libs/libpng:0=
+ >=media-libs/openjpeg-2.1:2=
+ >=media-libs/libjpeg-turbo-1.5.3-r2:0=
+ net-misc/curl
+ javascript? ( >=dev-lang/mujs-1.2.0:= )
+ opengl? ( >=media-libs/freeglut-3.0.0 )
+ ssl? ( >=dev-libs/openssl-1.1:0= )
+ sys-libs/zlib
+ X? (
+ media-libs/libglvnd[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.15-CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.19.0-Makefile.patch
+ "${FILESDIR}"/${PN}-1.21.0-add-desktop-pc-files.patch
+ "${FILESDIR}"/${PN}-1.23.3-darwin.patch
+ # See bugs #662352
+ "${FILESDIR}"/${PN}-1.23.3-openssl-x11.patch
+ # General cross fixes from Debian (refreshed)
+ "${FILESDIR}"/${PN}-1.23.3-cross-fixes.patch
+ "${FILESDIR}"/${PN}-1.21.1-fix-aliasing-violation.patch
+)
+
+src_prepare() {
+ default
+
+ use hppa && append-cflags -ffunction-sections
+
+ append-cflags "-DFZ_ENABLE_JS=$(usex javascript 1 0)"
+
+ sed -e "1iOS = Linux" \
+ -e "1iCC = $(tc-getCC)" \
+ -e "1iCXX = $(tc-getCXX)" \
+ -e "1iLD = $(tc-getLD)" \
+ -e "1iAR = $(tc-getAR)" \
+ -e "1iverbose = yes" \
+ -e "1ibuild = debug" \
+ -i Makerules || die "Failed adding build variables to Makerules in src_prepare()"
+
+ # Adjust MuPDF version in .pc file created by the
+ # mupdf-1.21.0-add-desktop-pc-files.patch file
+ sed -e "s/Version: \(.*\)/Version: ${PV}/" \
+ -i platform/debian/${PN}.pc || die "Failed substituting version in ${PN}.pc"
+}
+
+_emake() {
+ # When HAVE_OBJCOPY is yes, we end up with a lot of QA warnings.
+ #
+ # Bundled libs
+ # * General
+ # Note that USE_SYSTEM_LIBS=yes is a metaoption which will set to upstream's
+ # recommendations. It does not mean "always use system libs".
+ # See [0] below for what it means in a specific version.
+ #
+ # * freeglut
+ # We don't use system's freeglut because upstream has a special modified
+ # version of it that gives mupdf clipboard support. See bug #653298
+ #
+ # * mujs
+ # As of v1.15.0, mupdf started using symbols in mujs that were not part
+ # of any release. We then went back to using the bundled version of it.
+ # But v1.17.0 looks ok, so we'll go unbundled again. Be aware of this risk
+ # when bumping and check!
+ # See bug #685244
+ #
+ # * lmms2
+ # mupdf uses a bundled version of lcms2 [0] because Artifex have forked it [1].
+ # It is therefore not appropriate for us to unbundle it at this time.
+ #
+ # [0] https://git.ghostscript.com/?p=mupdf.git;a=blob;f=Makethird;h=c4c540fa4a075df0db85e6fdaab809099881f35a;hb=HEAD#l9
+ # [1] https://www.ghostscript.com/doc/lcms2mt/doc/WhyThisFork.txt
+ local myemakeargs=(
+ GENTOO_PV=${PV}
+ HAVE_GLUT=$(usex opengl)
+ HAVE_LIBCRYPTO=$(usex ssl)
+ HAVE_X11=$(usex X)
+ USE_SYSTEM_LIBS=yes
+ USE_SYSTEM_MUJS=$(usex javascript)
+ USE_SYSTEM_GLUT=no
+ HAVE_OBJCOPY=no
+ "$@"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+
+ _emake XCFLAGS="-fPIC"
+}
+
+src_install() {
+ if use opengl || use X ; then
+ domenu platform/debian/${PN}.desktop
+ doicon -s scalable docs/logo/new-${PN}-icon.svg
+ else
+ rm docs/man/${PN}.1 || die "Failed to remove man page in src_install()"
+ fi
+
+ sed -i \
+ -e "1iprefix = ${ED}/usr" \
+ -e "1ilibdir = ${ED}/usr/$(get_libdir)" \
+ -e "1idocdir = ${ED}/usr/share/doc/${PF}" \
+ -i Makerules || die "Failed adding liprefix, lilibdir and lidocdir to Makerules in src_install()"
+
+ _emake install
+
+ dosym libmupdf.so.${PV} /usr/$(get_libdir)/lib${PN}.so
+
+ if use opengl ; then
+ einfo "mupdf symlink points to mupdf-gl (bug 616654)"
+ dosym ${PN}-gl /usr/bin/${PN}
+ elif use X ; then
+ einfo "mupdf symlink points to mupdf-x11 (bug 616654)"
+ dosym ${PN}-x11 /usr/bin/${PN}
+ fi
+
+ # Respect libdir and EPREFIX (bugs #734898, #911965)
+ sed -i -e "s:/lib:/$(get_libdir):" \
+ -e "s:/usr:${EPREFIX}/usr:" platform/debian/${PN}.pc \
+ || die "Failed to sed pkgconfig file to respect libdir and EPREFIX in src_install()"
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins platform/debian/${PN}.pc
+
+ dodoc README CHANGES CONTRIBUTORS
+}