summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/multitail/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/multitail/files')
-rw-r--r--app-text/multitail/files/multitail-6.0-as-needed.patch36
-rw-r--r--app-text/multitail/files/multitail-6.3-as-needed.patch31
-rw-r--r--app-text/multitail/files/multitail-6.4.1-gentoo.patch31
3 files changed, 98 insertions, 0 deletions
diff --git a/app-text/multitail/files/multitail-6.0-as-needed.patch b/app-text/multitail/files/multitail-6.0-as-needed.patch
new file mode 100644
index 000000000000..c78bd794f699
--- /dev/null
+++ b/app-text/multitail/files/multitail-6.0-as-needed.patch
@@ -0,0 +1,36 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,14 +4,15 @@ UTF8_SUPPORT=yes
+ DESTDIR=/
+ CONFIG_FILE=$(DESTDIR)/etc/multitail.conf
+
+-CC=gcc
++CC?=gcc
++PKG_CONFIG?=pkg-config
+ DEBUG=-g -D_FORTIFY_SOURCE=2 # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
+ ifeq ($(UTF8_SUPPORT),yes)
+-LDFLAGS+=-lpanelw -lncursesw -lutil -lm $(DEBUG) -rdynamic
+-CFLAGS+=-funsigned-char -D`uname` -O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
++LIBS+=`$(PKG_CONFIG) --libs ncursesw panelw` -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
+ else
+-LDFLAGS+=-lpanel -lncurses -lutil -lm $(DEBUG) -rdynamic
+-CFLAGS+=-funsigned-char -D`uname` -O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
++LIBS+=`$(PKG_CONFIG) --libs ncurses panel` -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
+ endif
+
+ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o
+@@ -19,10 +20,10 @@ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.
+ all: multitail
+
+ multitail: $(OBJS)
+- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o multitail
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o multitail $(LIBS)
+
+ multitail_ccmalloc: $(OBJS)
+- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
++ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o ccmultitail $(LIBS)
+
+ install: multitail
+ cp multitail $(DESTDIR)/usr/bin
diff --git a/app-text/multitail/files/multitail-6.3-as-needed.patch b/app-text/multitail/files/multitail-6.3-as-needed.patch
new file mode 100644
index 000000000000..27b2cfaf1659
--- /dev/null
+++ b/app-text/multitail/files/multitail-6.3-as-needed.patch
@@ -0,0 +1,31 @@
+--- a/Makefile
++++ b/Makefile
+@@ -8,11 +8,11 @@ CONFIG_FILE=$(DESTDIR)/etc/multitail.conf
+ CC?=gcc
+ DEBUG=-g -O2 -Wall # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
+ ifeq ($(UTF8_SUPPORT),yes)
+-LDFLAGS+=-lpanelw -lncursesw -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT -D_FORTIFY_SOURCE=2
++LIBS+=`$(PKG_CONFIG) --libs ncursesw panelw` -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
+ else
+-LDFLAGS+=-lpanel -lncurses -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -D_FORTIFY_SOURCE=2
++LIBS+=`$(PKG_CONFIG) --libs ncurses panel` -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
+ endif
+
+ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o xclip.o
+@@ -20,10 +20,10 @@ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.
+ all: multitail
+
+ multitail: $(OBJS)
+- $(CC) $(OBJS) $(LDFLAGS) -o multitail
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o $@ $(LIBS)
+
+ multitail_ccmalloc: $(OBJS)
+- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
++ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o $@ $(LIBS)
+
+ install: multitail
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
diff --git a/app-text/multitail/files/multitail-6.4.1-gentoo.patch b/app-text/multitail/files/multitail-6.4.1-gentoo.patch
new file mode 100644
index 000000000000..080417b6b302
--- /dev/null
+++ b/app-text/multitail/files/multitail-6.4.1-gentoo.patch
@@ -0,0 +1,31 @@
+--- a/Makefile
++++ b/Makefile
+@@ -8,11 +8,11 @@
+ CC?=gcc
+ DEBUG+=-g -Wall # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
+ ifeq ($(UTF8_SUPPORT),yes)
+-LDFLAGS+=-lpanelw -lncursesw -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT -D_FORTIFY_SOURCE=2 -O3
++LIBS+=$(shell $(PKG_CONFIG) --libs ncursesw panelw) -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
+ else
+-LDFLAGS+=-lpanel -lncurses -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -D_FORTIFY_SOURCE=2 -O3
++LIBS+=$(shell $(PKG_CONFIG) --libs ncurses panel) -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\"
+ endif
+
+ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o xclip.o
+@@ -20,10 +20,10 @@
+ all: multitail
+
+ multitail: $(OBJS)
+- $(CC) $(OBJS) $(LDFLAGS) -o multitail
++ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) -o multitail $(LIBS)
+
+ multitail_ccmalloc: $(OBJS)
+- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
++ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail $(LIBS)
+
+ install: multitail
+ mkdir -p $(DESTDIR)$(PREFIX)/bin