summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-26 19:18:14 +0300
committerArsen Arsenović <arsen@gentoo.org>2024-09-18 15:06:30 +0200
commitbaf6d0529f1ddd62fcabeb5f4febf14e03739494 (patch)
tree16d326efce73996e1483b0770badd6a4e6eabbd2 /app-shells
parentapp-office/gnucash: switch to new guile mechanism (diff)
downloadgentoo-baf6d0529f1ddd62fcabeb5f4febf14e03739494.tar.gz
gentoo-baf6d0529f1ddd62fcabeb5f4febf14e03739494.tar.bz2
gentoo-baf6d0529f1ddd62fcabeb5f4febf14e03739494.zip
app-shells/gash: switch to new guile mechanism
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/gash/gash-0.3.0-r100.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-shells/gash/gash-0.3.0-r100.ebuild b/app-shells/gash/gash-0.3.0-r100.ebuild
new file mode 100644
index 000000000000..2dc3bad3b8f1
--- /dev/null
+++ b/app-shells/gash/gash-0.3.0-r100.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 2-2 3-0 )
+
+inherit guile-single
+
+DESCRIPTION="POSIX-compatible shell written in Guile Scheme"
+HOMEPAGE="https://savannah.nongnu.org/projects/gash/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+REQUIRED_USE="${QUILE_REQUIRED_USE}"
+
+RDEPEND="${GUILE_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo"
+
+src_prepare() {
+ guile-single_src_prepare
+
+ sed -i -e "s|guile|${GUILE}|" tests/temporary-assignments.org || die
+}