summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-16 09:17:42 +0000
committerSam James <sam@gentoo.org>2024-11-16 09:18:40 +0000
commit95189717d1bdf2c420b7c88935998a894dbeff8b (patch)
tree796b93a97898891d76addb92cc5ea278c4d587c9 /app-shells
parentapp-shells/bash: drop old 5.3 snapshots (diff)
downloadgentoo-95189717d1bdf2c420b7c88935998a894dbeff8b.tar.gz
gentoo-95189717d1bdf2c420b7c88935998a894dbeff8b.tar.bz2
gentoo-95189717d1bdf2c420b7c88935998a894dbeff8b.zip
app-shells/bash: pass -std=gnu17
GCC trunk now defaults to -std=gnu23 with which <bash-5.3 is not compatible so build with -std=gnu17. bash-5.3 is fine. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-2.05b_p13.ebuild4
-rw-r--r--app-shells/bash/bash-3.0_p22.ebuild4
-rw-r--r--app-shells/bash/bash-3.1_p23.ebuild4
-rw-r--r--app-shells/bash/bash-3.2_p57.ebuild4
-rw-r--r--app-shells/bash/bash-4.0_p44.ebuild6
-rw-r--r--app-shells/bash/bash-4.1_p17.ebuild6
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild6
-rw-r--r--app-shells/bash/bash-4.3_p48-r2.ebuild6
-rw-r--r--app-shells/bash/bash-4.4_p23-r2.ebuild6
-rw-r--r--app-shells/bash/bash-5.0_p18-r2.ebuild6
-rw-r--r--app-shells/bash/bash-5.1_p16-r13.ebuild4
-rw-r--r--app-shells/bash/bash-5.2_p26-r6.ebuild4
-rw-r--r--app-shells/bash/bash-5.2_p26-r8.ebuild4
-rw-r--r--app-shells/bash/bash-5.2_p37.ebuild4
14 files changed, 62 insertions, 6 deletions
diff --git a/app-shells/bash/bash-2.05b_p13.ebuild b/app-shells/bash/bash-2.05b_p13.ebuild
index 4d0475f67818..332d2e91577c 100644
--- a/app-shells/bash/bash-2.05b_p13.ebuild
+++ b/app-shells/bash/bash-2.05b_p13.ebuild
@@ -101,6 +101,10 @@ src_configure() {
# It works fine in bash 4+. Backporting may not be worth it.
filter-lto
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-3.0_p22.ebuild b/app-shells/bash/bash-3.0_p22.ebuild
index c134eaf7bf9a..432241662256 100644
--- a/app-shells/bash/bash-3.0_p22.ebuild
+++ b/app-shells/bash/bash-3.0_p22.ebuild
@@ -106,6 +106,10 @@ src_configure() {
# It works fine in bash 4+. Backporting may not be worth it.
filter-lto
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-3.1_p23.ebuild b/app-shells/bash/bash-3.1_p23.ebuild
index 2912f931bad0..7e9fb5554451 100644
--- a/app-shells/bash/bash-3.1_p23.ebuild
+++ b/app-shells/bash/bash-3.1_p23.ebuild
@@ -101,6 +101,10 @@ src_configure() {
# It works fine in bash 4+. Backporting may not be worth it.
filter-lto
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-3.2_p57.ebuild b/app-shells/bash/bash-3.2_p57.ebuild
index 48aea0430424..c00b1b641c4a 100644
--- a/app-shells/bash/bash-3.2_p57.ebuild
+++ b/app-shells/bash/bash-3.2_p57.ebuild
@@ -103,6 +103,10 @@ src_configure() {
# It works fine in bash 4+. Backporting may not be worth it.
filter-lto
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.0_p44.ebuild b/app-shells/bash/bash-4.0_p44.ebuild
index b54ac9fc6586..62b57fd03b03 100644
--- a/app-shells/bash/bash-4.0_p44.ebuild
+++ b/app-shells/bash/bash-4.0_p44.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -97,6 +97,10 @@ src_prepare() {
}
src_configure() {
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.1_p17.ebuild b/app-shells/bash/bash-4.1_p17.ebuild
index 1bf607050dd1..e17891fc9cb2 100644
--- a/app-shells/bash/bash-4.1_p17.ebuild
+++ b/app-shells/bash/bash-4.1_p17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -92,6 +92,10 @@ src_prepare() {
}
src_configure() {
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index 060e93efc14f..9736efa4fdb6 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -104,6 +104,10 @@ src_configure() {
# may misbehave at runtime.
unset YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--with-installed-readline=.
diff --git a/app-shells/bash/bash-4.3_p48-r2.ebuild b/app-shells/bash/bash-4.3_p48-r2.ebuild
index 024b3ee7d699..e5cd244c3acf 100644
--- a/app-shells/bash/bash-4.3_p48-r2.ebuild
+++ b/app-shells/bash/bash-4.3_p48-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -113,6 +113,10 @@ src_configure() {
# may misbehave at runtime.
unset YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--docdir='$(datarootdir)'/doc/${PF}
--htmldir='$(docdir)/html'
diff --git a/app-shells/bash/bash-4.4_p23-r2.ebuild b/app-shells/bash/bash-4.4_p23-r2.ebuild
index e890271eefc4..4c094621f6b4 100644
--- a/app-shells/bash/bash-4.4_p23-r2.ebuild
+++ b/app-shells/bash/bash-4.4_p23-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -124,6 +124,10 @@ src_configure() {
# may misbehave at runtime.
unset YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--disable-profiling
diff --git a/app-shells/bash/bash-5.0_p18-r2.ebuild b/app-shells/bash/bash-5.0_p18-r2.ebuild
index 021d85116030..9500f0a8c941 100644
--- a/app-shells/bash/bash-5.0_p18-r2.ebuild
+++ b/app-shells/bash/bash-5.0_p18-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -128,6 +128,10 @@ src_configure() {
# may misbehave at runtime.
unset YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
local myconf=(
--disable-profiling
diff --git a/app-shells/bash/bash-5.1_p16-r13.ebuild b/app-shells/bash/bash-5.1_p16-r13.ebuild
index eb7579fcf215..ddf5fd454024 100644
--- a/app-shells/bash/bash-5.1_p16-r13.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r13.ebuild
@@ -173,6 +173,10 @@ src_configure() {
# may misbehave at runtime.
unset -v YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
myconf=(
--disable-profiling
diff --git a/app-shells/bash/bash-5.2_p26-r6.ebuild b/app-shells/bash/bash-5.2_p26-r6.ebuild
index 0aa7f52a8c78..a65a93906d88 100644
--- a/app-shells/bash/bash-5.2_p26-r6.ebuild
+++ b/app-shells/bash/bash-5.2_p26-r6.ebuild
@@ -174,6 +174,10 @@ src_configure() {
# may misbehave at runtime.
unset -v YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
myconf=(
--disable-profiling
diff --git a/app-shells/bash/bash-5.2_p26-r8.ebuild b/app-shells/bash/bash-5.2_p26-r8.ebuild
index ca58c4740076..64edc6cd12b7 100644
--- a/app-shells/bash/bash-5.2_p26-r8.ebuild
+++ b/app-shells/bash/bash-5.2_p26-r8.ebuild
@@ -174,6 +174,10 @@ src_configure() {
# may misbehave at runtime.
unset -v YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
myconf=(
--disable-profiling
diff --git a/app-shells/bash/bash-5.2_p37.ebuild b/app-shells/bash/bash-5.2_p37.ebuild
index acb56fbe1e75..b30759530f7b 100644
--- a/app-shells/bash/bash-5.2_p37.ebuild
+++ b/app-shells/bash/bash-5.2_p37.ebuild
@@ -174,6 +174,10 @@ src_configure() {
# may misbehave at runtime.
unset -v YACC
+ # bash 5.3 drops unprototyped functions, earlier versions are
+ # incompatible with C23.
+ append-cflags -std=gnu17
+
myconf=(
--disable-profiling