summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-24 19:15:33 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-24 19:21:03 -0700
commit09a124492c3bef396d42acfa1d51a7b0cf996de3 (patch)
tree628fbd9c22ef2ccc4b39fd4429a3139f02b6eaf8 /app-shells/fzy/fzy-1.0-r1.ebuild
parentsci-libs/trilinos: fix DESTDIR and installation (diff)
downloadgentoo-09a124492c3bef396d42acfa1d51a7b0cf996de3.tar.gz
gentoo-09a124492c3bef396d42acfa1d51a7b0cf996de3.tar.bz2
gentoo-09a124492c3bef396d42acfa1d51a7b0cf996de3.zip
app-shells/fzy: revbump, respect LDFLAGS
Closes: https://bugs.gentoo.org/719072 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-shells/fzy/fzy-1.0-r1.ebuild')
-rw-r--r--app-shells/fzy/fzy-1.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/fzy/fzy-1.0-r1.ebuild b/app-shells/fzy/fzy-1.0-r1.ebuild
new file mode 100644
index 000000000000..660ca21138e7
--- /dev/null
+++ b/app-shells/fzy/fzy-1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jhawthorn/fzy.git"
+else
+ SRC_URI="https://github.com/jhawthorn/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 arm arm64 ~ppc64 x86"
+fi
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/1.0-cflags.patch )
+
+src_prepare() {
+ default
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dobin contrib/fzy-tmux
+ dobin contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}
+
+pkg_postinst() {
+ savedconfig_pkg_postinst
+ optfeature "opening search results in dvtm pane with provided ${EPREFIX}/usr/bin/fzy-dvtm" app-misc/dvtm
+ optfeature "opening search results in tmux pane with provided ${EPREFIX}/usr/bin/fzy-tmux" app-misc/tmux
+}