summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-03-24 19:53:16 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-03-27 11:08:04 +0100
commit624ba2504e489972a8d5c511628352bcc8748803 (patch)
tree5716e5143fce2dbaa221f2673c027003c16308f9 /app-office/scribus
parentnet-misc/teamviewer: Version bump (v15.4.4445) (diff)
downloadgentoo-624ba2504e489972a8d5c511628352bcc8748803.tar.gz
gentoo-624ba2504e489972a8d5c511628352bcc8748803.tar.bz2
gentoo-624ba2504e489972a8d5c511628352bcc8748803.zip
app-office/scribus: fix startup crash
The patch fixes the crash on startup, as well as a zlib package finding related issue in src_configure. It also solves an issue whith selecting the correct python implementation. Bug: https://bugs.gentoo.rog/691684 Package-Manager: Portage-2.3.95, Repoman-2.3.21 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://bugs.gentoo.org/691684 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-office/scribus')
-rw-r--r--app-office/scribus/scribus-9999.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-office/scribus/scribus-9999.ebuild b/app-office/scribus/scribus-9999.ebuild
index 97d62f8d370d..9d0977e8bd7c 100644
--- a/app-office/scribus/scribus-9999.ebuild
+++ b/app-office/scribus/scribus-9999.ebuild
@@ -80,18 +80,13 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.5.6-findhyphen.patch
)
+CMAKE_BUILD_TYPE="Release"
+
src_prepare() {
cmake_src_prepare
rm -r codegen/cheetah scribus/third_party/hyphen || die
- cat > cmake/modules/FindZLIB.cmake <<- EOF || die
- find_package(PkgConfig)
- pkg_check_modules(ZLIB minizip zlib)
- SET( ZLIB_LIBRARY \${ZLIB_LIBRARIES} )
- SET( ZLIB_INCLUDE_DIR \${ZLIB_INCLUDE_DIRS} )
- MARK_AS_ADVANCED( ZLIB_LIBRARY ZLIB_INCLUDE_DIR )
- EOF
sed \
-e "/^\s*unzip\.[ch]/d" \
-e "/^\s*ioapi\.[ch]/d" \
@@ -115,6 +110,7 @@ src_configure() {
-DHAVE_PYTHON=ON
-DWANT_DISTROBUILD=ON
-DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/
+ -DPython3_EXECUTABLE="${PYTHON}"
-DWITH_BOOST=$(usex boost)
-DWANT_DEBUG=$(usex debug)
-DWANT_NOEXAMPLES=$(usex !examples)