summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 00:27:53 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:30:32 -0400
commit56b5f6e31e082aa5a00e8299cee139f2f2f171ee (patch)
treef08a113857578355f89c163cf2a7bb76b22b1e72 /app-office/magicpoint
parentapp-misc/oneko: force gcc -E for imake's generation (diff)
downloadgentoo-56b5f6e31e082aa5a00e8299cee139f2f2f171ee.tar.gz
gentoo-56b5f6e31e082aa5a00e8299cee139f2f2f171ee.tar.bz2
gentoo-56b5f6e31e082aa5a00e8299cee139f2f2f171ee.zip
app-office/magicpoint: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. wrt #729526, not entirely fixed as still broken with clang16 Bug: https://bugs.gentoo.org/729526 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-office/magicpoint')
-rw-r--r--app-office/magicpoint/magicpoint-1.13a_p20121015-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-office/magicpoint/magicpoint-1.13a_p20121015-r2.ebuild b/app-office/magicpoint/magicpoint-1.13a_p20121015-r2.ebuild
index 4c584b1af2c8..4ed63f9f0fa0 100644
--- a/app-office/magicpoint/magicpoint-1.13a_p20121015-r2.ebuild
+++ b/app-office/magicpoint/magicpoint-1.13a_p20121015-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,6 +49,7 @@ DEPEND="
x11-libs/libxkbfile"
BDEPEND="
app-text/rman
+ sys-devel/gcc
virtual/pkgconfig
x11-base/xorg-proto
>=x11-misc/imake-1.0.8-r1
@@ -112,7 +113,7 @@ src_configure() {
econf "${myeconfargs[@]}"
- export IMAKECPP="${IMAKECPP:-$(tc-getCPP)}"
+ export IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}"
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" xmkmf || die
}