summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-03-09 08:01:05 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-03-09 08:02:25 +0200
commit7d5f3750b08a9713c20fe75d6685c5c50a3ff1ff (patch)
tree6c630136f7519cead3b036117cb8a31385108bf1 /app-misc
parentapp-vim/gentoo-syntax: Bump to v8 (diff)
downloadgentoo-7d5f3750b08a9713c20fe75d6685c5c50a3ff1ff.tar.gz
gentoo-7d5f3750b08a9713c20fe75d6685c5c50a3ff1ff.tar.bz2
gentoo-7d5f3750b08a9713c20fe75d6685c5c50a3ff1ff.zip
app-misc/trash-cli: add 0.23.2.13.2, PEP517, py3.11
Closes: https://bugs.gentoo.org/896602 Closes: https://github.com/mgorny/python-bump-testing/issues/38 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 2f6822d6bffc..c454aa23bb50 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,2 +1,3 @@
DIST trash-cli-0.22.8.21.tar.gz 79315 BLAKE2B a4b0f3072d9a9091b90bec13e3a8208c58638f7dd054a788ba0126f8c803748c837dbf183513ca87a775d4efbed9e926603b2b3839f9f499963b774f59f06cd5 SHA512 9c8a40cd92c070dfcadfe2a4871c16a3cfc066568f0e079e11ff80aff53777335f1fec42245846bba04866a55ba9d11a2493950ccdcefcd7d98825508eb6ab6b
DIST trash-cli-0.22.8.27.tar.gz 80344 BLAKE2B 309a1c429b6e052d622f5cd0f4eb211e1dcf8f5fcbe0834d359cd568527843e6a3c4cd1d61f1d1102b6e7f5b7a55fdde396b2500ca94f9410111705cdbff339b SHA512 909a521f40e2252012ed9ebafe8baff50cd2f743c9ab49df0abb41ecc177e551bde07289505f37e8dc86a0d20cdc8b521c35dd2383d17d4f9e962aa431368fe8
+DIST trash-cli-0.23.2.13.2.gh.tar.gz 104006 BLAKE2B c4187faff6618c54be3fcda2fca799d16ff614e5db2a47912aa796d72385bac8dab188977f635372372eae3f6e7d0faaea9405ac93edcd06962f6ffc2bd4694d SHA512 3894d852c01f5e3096bc5bf95220c35cfaa28e2fa555716983ad8203ce7d2206127394cdfbf3f08f0922abdbbfdb4f1a6c1db3fb0bcbda9d936612a2c7d6a7e8
diff --git a/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild b/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild
new file mode 100644
index 000000000000..e0ef904bfe15
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="
+ https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}