summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 10:38:56 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:10:47 +0100
commit5ef378748982f61d00bb60172d661be41ddc5f1c (patch)
tree27db42a4caa00d819093bbd29aa0a97e98eeaa59 /app-misc
parentapp-i18n/tomoe: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-5ef378748982f61d00bb60172d661be41ddc5f1c.tar.gz
gentoo-5ef378748982f61d00bb60172d661be41ddc5f1c.tar.bz2
gentoo-5ef378748982f61d00bb60172d661be41ddc5f1c.zip
app-misc/anki: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki/anki-2.1.0_beta25.ebuild32
-rw-r--r--app-misc/anki/anki-2.1.0_beta27.ebuild42
-rw-r--r--app-misc/anki/anki-2.1.13-r1.ebuild (renamed from app-misc/anki/anki-2.1.13.ebuild)34
3 files changed, 63 insertions, 45 deletions
diff --git a/app-misc/anki/anki-2.1.0_beta25.ebuild b/app-misc/anki/anki-2.1.0_beta25.ebuild
index 7a709e1e39e3..7e5c0bc5b290 100644
--- a/app-misc/anki/anki-2.1.0_beta25.ebuild
+++ b/app-misc/anki/anki-2.1.0_beta25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,17 +23,19 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- dev-python/PyQt5[gui,svg,webkit,${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- recording? (
- media-sound/lame
- >=dev-python/pyaudio-0.2.4[${PYTHON_USEDEP}]
- )
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[gui,svg,webkit,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+ dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ recording? (
+ media-sound/lame
+ >=dev-python/pyaudio-0.2.4[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
sound? ( media-video/mplayer )
latex? (
app-text/texlive
@@ -41,7 +43,11 @@ RDEPEND="${PYTHON_DEPS}
)
"
DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
PATCHES=( "${FILESDIR}"/${P}-web-folder.patch )
diff --git a/app-misc/anki/anki-2.1.0_beta27.ebuild b/app-misc/anki/anki-2.1.0_beta27.ebuild
index 341c641fe86e..9b0a46164d62 100644
--- a/app-misc/anki/anki-2.1.0_beta27.ebuild
+++ b/app-misc/anki/anki-2.1.0_beta27.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,23 +23,25 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- || (
- (
- >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_USEDEP}]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ || (
+ (
+ >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+ )
+ <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_MULTI_USEDEP}]
)
- <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_USEDEP}]
- )
- >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- recording? (
- media-sound/lame
- >=dev-python/pyaudio-0.2.4[${PYTHON_USEDEP}]
- )
+ >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+ dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ recording? (
+ media-sound/lame
+ >=dev-python/pyaudio-0.2.4[${PYTHON_MULTI_USEDEP}]
+ )
+ ')
sound? ( media-video/mplayer )
latex? (
app-text/texlive
@@ -47,7 +49,11 @@ RDEPEND="${PYTHON_DEPS}
)
"
DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
PATCHES=( "${FILESDIR}"/${PN}-2.1.0_beta25-web-folder.patch )
diff --git a/app-misc/anki/anki-2.1.13.ebuild b/app-misc/anki/anki-2.1.13-r1.ebuild
index 15c2f2cdf075..9c1a33eea458 100644
--- a/app-misc/anki/anki-2.1.13.ebuild
+++ b/app-misc/anki/anki-2.1.13-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,19 +22,21 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- || (
- (
- >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_USEDEP}]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ || (
+ (
+ >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+ )
+ <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_MULTI_USEDEP}]
)
- <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_USEDEP}]
- )
- >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+ dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ ')
recording? ( media-sound/lame )
sound? ( media-video/mpv )
latex? (
@@ -43,7 +45,11 @@ RDEPEND="${PYTHON_DEPS}
)
"
DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
PATCHES=( "${FILESDIR}"/${PN}-2.1.0_beta25-web-folder.patch )