summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/empty
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/empty')
-rw-r--r--app-misc/empty/Manifest1
-rw-r--r--app-misc/empty/empty-0.6.19b.ebuild33
-rw-r--r--app-misc/empty/files/empty-respect-LDFLAGS.patch11
-rw-r--r--app-misc/empty/files/overflow-fixes.patch20
-rw-r--r--app-misc/empty/metadata.xml11
5 files changed, 76 insertions, 0 deletions
diff --git a/app-misc/empty/Manifest b/app-misc/empty/Manifest
new file mode 100644
index 000000000000..0b6d09bfd28d
--- /dev/null
+++ b/app-misc/empty/Manifest
@@ -0,0 +1 @@
+DIST empty-0.6.19b.tgz 16075 SHA256 05b7cb361ef815774abda325c09c573f8c9039ccbb71eedc743439e4637c314a SHA512 7afb2b5d08f2d3ebe0819eccef39b2e35fa532b6cbdcef49d2dbb4a5aa57fe55b1765461de9691d6eaa3188a9ecd98c291de738c13c9c2158c4f53d704b83670 WHIRLPOOL ed003801da923de6b50e6b29313b5603c18b98851e7523971b7a1059c9d14bc9545726437c6c8c41427fe7fbac531469aa7500ffb324f3cd77682208da88088b
diff --git a/app-misc/empty/empty-0.6.19b.ebuild b/app-misc/empty/empty-0.6.19b.ebuild
new file mode 100644
index 000000000000..80250f945625
--- /dev/null
+++ b/app-misc/empty/empty-0.6.19b.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Small shell utility, similar to expect(1)"
+HOMEPAGE="http://empty.sourceforge.net"
+SRC_URI="mirror://sourceforge/empty/${P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="amd64 x86"
+IUSE="examples"
+DEPEND=""
+RDEPEND="virtual/logger"
+
+src_prepare() {
+ epatch "${FILESDIR}/overflow-fixes.patch"
+ epatch "${FILESDIR}/${PN}-respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin empty
+ doman empty.1
+ dodoc README
+ use examples && dodoc -r examples
+}
diff --git a/app-misc/empty/files/empty-respect-LDFLAGS.patch b/app-misc/empty/files/empty-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..f839afcf28c9
--- /dev/null
+++ b/app-misc/empty/files/empty-respect-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- empty-0.6.18b/Makefile
++++ empty-0.6.18b/Makefile
+@@ -16,7 +16,7 @@
+ PREFIX = /usr/local
+
+ all:
+- ${CC} ${CFLAGS} -Wall ${LIBS} -o empty empty.c
++ ${CC} ${CFLAGS} ${LDFLAGS} empty.c ${LIBS} -o empty
+
+ FreeBSD: all
+ NetBSD: all
diff --git a/app-misc/empty/files/overflow-fixes.patch b/app-misc/empty/files/overflow-fixes.patch
new file mode 100644
index 000000000000..96dd18024a03
--- /dev/null
+++ b/app-misc/empty/files/overflow-fixes.patch
@@ -0,0 +1,20 @@
+--- empty.c.orig 2009-07-27 18:26:42.000000000 +0100
++++ empty.c 2011-12-22 17:17:11.037090159 +0000
+@@ -584,7 +584,7 @@
+
+ for (i = 1; i < argc; i++) {
+ strncat(buf, " ", 1);
+- strncat(buf, argv[i], sizeof(buf));
++ strncat(buf, argv[i], sizeof(buf) -1);
+ }
+
+ (void)syslog(LOG_NOTICE, "forked %s", buf);
+@@ -686,7 +686,7 @@
+ while ((dent = readdir(dir)) != NULL) {
+ if (!strncmp(fmask, dent->d_name, len)) {
+ strncpy(fname, dent->d_name, sizeof(fname) - 1);
+- fname[sizeof(buf) - 1] = '\0';
++ fname[MAXPATHLEN - 1] = '\0';
+
+ strtok(fname, sep); /* empty */
+ strtok(NULL, sep); /* PPID */
diff --git a/app-misc/empty/metadata.xml b/app-misc/empty/metadata.xml
new file mode 100644
index 000000000000..08e6bc8cd26e
--- /dev/null
+++ b/app-misc/empty/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">empty</remote-id>
+ </upstream>
+</pkgmetadata>