summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2024-11-30 00:48:34 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2024-11-30 00:48:34 +0100
commitefb38ea0c9efafa4b62c4a710dc3fabc26cb392f (patch)
tree893b56c4a110a5a1f3ffa1ee8dd6b388850c91ad /app-laptop
parentapp-laptop/tuxedo-drivers: add 4.11.4, drop 4.5.0 (diff)
downloadgentoo-efb38ea0c9efafa4b62c4a710dc3fabc26cb392f.tar.gz
gentoo-efb38ea0c9efafa4b62c4a710dc3fabc26cb392f.tar.bz2
gentoo-efb38ea0c9efafa4b62c4a710dc3fabc26cb392f.zip
app-laptop/tuxedo-drivers: add config checks
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tuxedo-drivers/tuxedo-drivers-4.11.4-r1.ebuild (renamed from app-laptop/tuxedo-drivers/tuxedo-drivers-4.11.4.ebuild)17
1 files changed, 17 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-drivers/tuxedo-drivers-4.11.4.ebuild b/app-laptop/tuxedo-drivers/tuxedo-drivers-4.11.4-r1.ebuild
index 7d05531d1cef..55a673c07c8c 100644
--- a/app-laptop/tuxedo-drivers/tuxedo-drivers-4.11.4.ebuild
+++ b/app-laptop/tuxedo-drivers/tuxedo-drivers-4.11.4-r1.ebuild
@@ -18,6 +18,23 @@ KEYWORDS="~amd64 ~x86"
PATCHES=( )
+pkg_setup() {
+ local CONFIG_CHECK="
+ ACPI_WMI
+ IIO
+ INPUT_SPARSEKMAP
+ LEDS_CLASS_MULTICOLOR
+ "
+
+ local ERROR_LEDS_CLASS_MULTICOLOR="CONFIG_LEDS_CLASS_MULTICOLOR: is required for keyboard backlight"
+
+ local ERROR_ACPI_WMI="CONFIG_ACPI_WMI: is required for tuxedo-drivers"
+ local ERROR_INPUT_SPARSEKMAP="CONFIG_INPUT_SPARSEKMAP: is required for tuxedo-drivers"
+ local ERROR_IIOP="CONFIG_IIO: is required for tuxedo-drivers"
+
+ linux-mod-r1_pkg_setup
+}
+
src_compile() {
local modlist=(
clevo_acpi=tuxedo::src