summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-laptop/hdaps-gl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-laptop/hdaps-gl')
-rw-r--r--app-laptop/hdaps-gl/Manifest1
-rw-r--r--app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff11
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild34
-rw-r--r--app-laptop/hdaps-gl/metadata.xml10
4 files changed, 56 insertions, 0 deletions
diff --git a/app-laptop/hdaps-gl/Manifest b/app-laptop/hdaps-gl/Manifest
new file mode 100644
index 000000000000..fa8391ed8604
--- /dev/null
+++ b/app-laptop/hdaps-gl/Manifest
@@ -0,0 +1 @@
+DIST hdaps-gl-0.0.5.tar.gz 2495 SHA256 d7696a42be66b09d492345c3a05b7c3b45f5e8e33464d3a74844b78182c73c64 SHA512 6ebef6324fcdfaf5c2ec6cc8382d376c711e5d957a4ffdd4ee150317649ea0a47552e421f8008a3498ac49487657dca2f49b1a50169d7ab02ee5bef856625d19 WHIRLPOOL 1e8182f8d6e7c378204c2b91c4bb9d8a7574b3d636485e1349b037c82feee06985ee9d4e9e7cc155d5c67b2bb81739a6ff9350a29e87ac5f7d16efedec1ad1fa
diff --git a/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff b/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff
new file mode 100644
index 000000000000..0d0214033252
--- /dev/null
+++ b/app-laptop/hdaps-gl/files/hdaps-gl-0.0.5-as-needed.diff
@@ -0,0 +1,11 @@
+--- hdaps-gl-0.0.5/Makefile 2005-08-30 20:06:53.000000000 +0200
++++ hdaps-gl-0.0.5-1/Makefile 2008-09-22 22:55:57.000000000 +0200
+@@ -10,7 +10,7 @@
+ all: hdaps-gl
+
+ hdaps-gl: hdaps-gl.c
+- $(CC) $(CFLAGS) $(LIBDIR) $(LIBRARIES) -o hdaps-gl hdaps-gl.c
++ $(CC) $(CFLAGS) $(LIBDIR) -o hdaps-gl hdaps-gl.c $(LIBRARIES)
+
+ clean:
+ rm -f hdaps-gl *.o
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
new file mode 100644
index 000000000000..e3cc49627890
--- /dev/null
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenGL visualization for HDAPS data"
+HOMEPAGE="http://hdaps.sourceforge.net"
+SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/freeglut"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-as-needed.diff"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/app-laptop/hdaps-gl/metadata.xml b/app-laptop/hdaps-gl/metadata.xml
new file mode 100644
index 000000000000..1f206e8e76da
--- /dev/null
+++ b/app-laptop/hdaps-gl/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hdaps</remote-id>
+ </upstream>
+</pkgmetadata>