summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-28 10:17:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-28 10:45:28 +0200
commit99f798af9636c338696f770381c897dec35e0910 (patch)
treefaf0a0dceb5a0b85101ee235004e80cdede0ed3d /app-eselect
parentdev-util/lldb: Check cmake directory out for 15.x (diff)
downloadgentoo-99f798af9636c338696f770381c897dec35e0910.tar.gz
gentoo-99f798af9636c338696f770381c897dec35e0910.tar.bz2
gentoo-99f798af9636c338696f770381c897dec35e0910.zip
app-eselect/eselect-repository: Enable py3.11
Closes: https://bugs.gentoo.org/861671 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-repository/eselect-repository-12.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-eselect/eselect-repository/eselect-repository-12.ebuild b/app-eselect/eselect-repository/eselect-repository-12.ebuild
index 1914e75a3925..2cc2fc5af707 100644
--- a/app-eselect/eselect-repository/eselect-repository-12.ebuild
+++ b/app-eselect/eselect-repository/eselect-repository-12.ebuild
@@ -7,8 +7,11 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit python-single-r1
DESCRIPTION="Manage repos.conf via eselect"
-HOMEPAGE="https://github.com/mgorny/eselect-repository"
-SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/mgorny/eselect-repository/"
+SRC_URI="
+ https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="BSD-2"
SLOT="0"
@@ -17,18 +20,21 @@ IUSE="test"
RESTRICT="!test? ( test )"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
app-admin/eselect
$(python_gen_cond_dep '
dev-python/lxml[${PYTHON_USEDEP}]
')
- net-misc/wget"
+ net-misc/wget
+"
BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/pytest[${PYTHON_USEDEP}]
')
- )"
+ )
+"
src_compile() {
MAKEARGS=(