summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-27 14:37:26 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-27 14:45:49 -0400
commit0c0c9072bebf9ecd237ccccba1cfd7999f1c9c59 (patch)
treef0ee9e510e1baf6abbc564c9bb2ed7a4d7eca73e /app-eselect/eselect-unison/eselect-unison-0.4.ebuild
parentdev-db/mysql-init-scripts: Use tmpfiles eclass during install (diff)
downloadgentoo-0c0c9072bebf9ecd237ccccba1cfd7999f1c9c59.tar.gz
gentoo-0c0c9072bebf9ecd237ccccba1cfd7999f1c9c59.tar.bz2
gentoo-0c0c9072bebf9ecd237ccccba1cfd7999f1c9c59.zip
app-eselect/eselect-unison: bump to 0.4
This adds support for slotted fsmonitor which will be added in upcoming net-misc/unison ebuilds Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-eselect/eselect-unison/eselect-unison-0.4.ebuild')
-rw-r--r--app-eselect/eselect-unison/eselect-unison-0.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-eselect/eselect-unison/eselect-unison-0.4.ebuild b/app-eselect/eselect-unison/eselect-unison-0.4.ebuild
new file mode 100644
index 000000000000..d8f2e3d228f2
--- /dev/null
+++ b/app-eselect/eselect-unison/eselect-unison-0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="unison module for eselect"
+HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="unison"
+ dodir ${MODULEDIR}
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect
+}