summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-09-09 18:23:16 +0100
committerMarkos Chandras <hwoarang@gentoo.org>2015-09-09 18:25:29 +0100
commit2e5484e0e131495e2175d5b6c6eb3f1e29d93075 (patch)
treeb6e8e8695d32d6680ad2798944d7849b889ee1f5 /app-emulation
parentdev-ruby/metasploit-payloads: restrict strip, it makes no sense for this pack... (diff)
downloadgentoo-2e5484e0e131495e2175d5b6c6eb3f1e29d93075.tar.gz
gentoo-2e5484e0e131495e2175d5b6c6eb3f1e29d93075.tar.bz2
gentoo-2e5484e0e131495e2175d5b6c6eb3f1e29d93075.zip
app-emulation/phpvirtualbox: Version bump (#556738 by Mickaël Bucas)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/phpvirtualbox/Manifest1
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-5.0.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-emulation/phpvirtualbox/Manifest b/app-emulation/phpvirtualbox/Manifest
index 4085d43205b8..b8425709c3ab 100644
--- a/app-emulation/phpvirtualbox/Manifest
+++ b/app-emulation/phpvirtualbox/Manifest
@@ -4,3 +4,4 @@ DIST phpvirtualbox-4.2-3b.zip 3184088 SHA256 23134a05d22ac9429524abb9d7165eb4c0e
DIST phpvirtualbox-4.2-4.zip 3663173 SHA256 dd2681dc9703ec68a995cac98719863dca9e0720e45f5e0322dbb6fa3858138b SHA512 51e3b90bb5fcedbd45a6e54cf3ea6cc74cd764bdc107f97f9cb24c27f2c5d53a862781b808ab7d53cdbbd9d4cff93734d7578676b409d10326895dd1c5dcdc15 WHIRLPOOL 1678790492df50f7ae63bd4b44dbcd0ddd892c1bef9d455bf47bb20f1dcdac4955645fe71d549095ccc4a19f5960abf0f34fa1d95c4f4c8d82a34848a405fe06
DIST phpvirtualbox-4.2-7.zip 3425805 SHA256 3dc078d7058d75aa5745f531a6d485a11fff18972df1a638a749f019e0196e4e SHA512 a066f127115a83c6061e8c0ff6447464818511f3ab7805c119f75ddc88459efd144d45fb358ce52959301f2f1a4f2609f7f42c2bb24213a5be98f2036085a81b WHIRLPOOL d6cf095b9768b7a9c0113c8df354dad124a0b2dc0a52e8518dfde230823c95dcad6b6e3df56cc41a4474b8b73cb281f3bfc91f417078e0b6f1136acd70dca4cf
DIST phpvirtualbox-4.3-0.zip 4231805 SHA256 e33eea5553fb134ba6a1203e33e212bc5764c05b28164dcc02c6d66af565c293 SHA512 fd49a6a4c79d75f37fd40d74743f295a148548373ab046cf1f31ef7b982008ea6b9d2838cdad2dc37a1d266ed630cd2ddb7f7423ea62af1e0f8f9f76a12c0e9d WHIRLPOOL 1c96ec2fe19092dabac9e04be596974cc4dbaa9993c34e76b938036e8e04c67dc4f4f344be8afd636d603a478ce0c85435a75f8d6cf59bbdc3a11c6fd575b6c1
+DIST phpvirtualbox-5.0-3.zip 4092132 SHA256 8e23eee4ee36ff8cf765afb6842338e8ea8190956882ec0baa30f09ff4fe134b SHA512 b632ff3be2028bd011ce27b580996638dfc89e09350c459f16bd1c8c5c3eefbab93f42d7facfb99279eb2ee1c6a38854ea999654ca2090a39c7bfa0afa7fe2d5 WHIRLPOOL 38070a6935e3a4e5155f84db395c9e82603583957b26fcf166a654446052b15aa3d3b7653a9f7d56a33382dc82058e55413575e75c26b4c97f782bb868cc66e8
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-5.0.3.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-5.0.3.ebuild
new file mode 100644
index 000000000000..c26844f4dd39
--- /dev/null
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-5.0.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.3.0.ebuild,v 1.1 2013/11/15 21:20:46 hwoarang Exp $
+
+EAPI="5"
+
+inherit versionator eutils webapp depend.php readme.gentoo
+
+MY_PV="$(replace_version_separator 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="https://sourceforge.net/projects/phpvirtualbox/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php[session,unicode,soap,gd]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_httpd
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+Local or remote virtualbox hosts must be compiled with
+'vboxwebsrv' useflag and the respective init script
+must be running to use this interface:
+/etc/init.d/vboxwebsrv start
+
+To enable the automatic startup mode feature uncomment the
+following line in the config.php file:
+var \$startStopConfig = true;
+
+You should also add the /etc/init.d/vboxinit script to the
+default runlevel on the virtualbox host:
+\`rc-update add vboxinit default\`
+If the server is on a remote host, than the script must be
+copied manually from
+'${FILESDIR}'/vboxinit-initd to
+/etc/init.d/vboxinit on the remote host."
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.txt LICENSE.txt README.txt
+ rm -f CHANGELOG.txt LICENSE.txt README.txt
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+ webapp_src_install
+ if has_version app-emulation/virtualbox[vboxwebsrv] || \
+ has_version app-emulation/virtualbox-bin[vboxwebsrv]
+ then
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ readme.gentoo_print_elog
+}