summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-10-03 13:16:35 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-10-03 13:21:36 +0300
commit5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb (patch)
tree85d1d64917624b1e2bcd3bbef0075aeb325c7c5f /app-emulation/dynamips/dynamips-0.2.18.ebuild
parentapp-emulation/dynamips: revision bump (diff)
downloadgentoo-5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb.tar.gz
gentoo-5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb.tar.bz2
gentoo-5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb.zip
app-emulation/dynamips: version bump
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-emulation/dynamips/dynamips-0.2.18.ebuild')
-rw-r--r--app-emulation/dynamips/dynamips-0.2.18.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/dynamips/dynamips-0.2.18.ebuild b/app-emulation/dynamips/dynamips-0.2.18.ebuild
new file mode 100644
index 000000000000..1b58ec9cfdad
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.18.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="https://github.com/GNS3/dynamips"
+SRC_URI="https://github.com/GNS3/dynamips/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ipv6"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DOCS=( ChangeLog README.md RELEASE-NOTES )
+
+PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+
+src_prepare() {
+ # comment out DYNAMIPS_FLAGS to respect CFLAGS
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DANY_COMPILER=1
+ -DENABLE_IPV6="$(usex ipv6)"
+ )
+ cmake-utils_src_configure
+}