summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-21 02:26:33 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-21 02:51:11 +0200
commit9306d483a299adb9df6fd5a3a1328176cef6c69f (patch)
tree551f163a86b7e7af9f324c11d8cec803038da5f3 /app-emacs
parentdev-python/ytmusicapi: bump to 1.7.2 (diff)
downloadgentoo-9306d483a299adb9df6fd5a3a1328176cef6c69f.tar.gz
gentoo-9306d483a299adb9df6fd5a3a1328176cef6c69f.tar.bz2
gentoo-9306d483a299adb9df6fd5a3a1328176cef6c69f.zip
dev-dotnet/dotnet-sdk: bump to 8.0.105
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/auctex/Manifest1
-rw-r--r--app-emacs/auctex/auctex-14.0.5.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-emacs/auctex/Manifest b/app-emacs/auctex/Manifest
index 8e022ae758eb..3fcfe4c0841a 100644
--- a/app-emacs/auctex/Manifest
+++ b/app-emacs/auctex/Manifest
@@ -1 +1,2 @@
DIST auctex-13.3.tar.gz 1695608 BLAKE2B 3a22273b72237e14a31a1fb9d81e2c4ee10290919bc3d6f8cb35ab877ef26083c7edb5bbb7c88a40f45848012cc2edd375a90d872f604029ba8f03278bd95f9a SHA512 32d6f3c968a27dd5e7862993419bfa0f5e5228abca7478341a06fce153f333410cd230f8266e6b0e4fb5e4247864710e3f572b6a837c99c2879d38899590f678
+DIST auctex-14.0.5.tar.xz 1006368 BLAKE2B 66d382568072be804707c2bab3d1d2eda315999c0ca509a95cb9e7005fded9cd9160c6cbc22bff254937ed717d003dbb0c16498d68512e5f7c2807ae55aeccf2 SHA512 c1e1458d0b0147e597b92ca22326218968540b4069067821998a0eafae9c9b193257dd1da075a53329ba990bff4594e1430bd8da3ee1617c5394aab541e60606
diff --git a/app-emacs/auctex/auctex-14.0.5.ebuild b/app-emacs/auctex/auctex-14.0.5.ebuild
new file mode 100644
index 000000000000..7023de563f3d
--- /dev/null
+++ b/app-emacs/auctex/auctex-14.0.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extensible package for writing and formatting TeX files in Emacs"
+HOMEPAGE="https://www.gnu.org/software/auctex/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/auctex.git"
+else
+ SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+IUSE="preview-latex"
+
+RDEPEND="
+ virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+TEXMF="/usr/share/texmf-site"
+
+src_configure() {
+ local -a myconf=(
+ --with-emacs
+ --with-auto-dir="${EPREFIX}/var/lib/auctex"
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}"
+ --with-texmf-dir="${EPREFIX}${TEXMF}"
+ --disable-build-dir-test
+ $(use_enable preview-latex preview)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ VARTEXFONTS="${T}/fonts" emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${ED}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+
+ if use preview-latex ; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+
+ dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ use preview-latex && texmf-update
+
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ use preview-latex && texmf-update
+
+ elisp-site-regen
+}