summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/yc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/yc')
-rw-r--r--app-emacs/yc/Manifest1
-rw-r--r--app-emacs/yc/files/50yc-gentoo.el4
-rw-r--r--app-emacs/yc/files/sample.dot.emacs-412
-rw-r--r--app-emacs/yc/files/sample.hosts.canna2
-rw-r--r--app-emacs/yc/metadata.xml6
-rw-r--r--app-emacs/yc/yc-4.0.13.ebuild56
6 files changed, 81 insertions, 0 deletions
diff --git a/app-emacs/yc/Manifest b/app-emacs/yc/Manifest
new file mode 100644
index 000000000000..2bc1bd6320a0
--- /dev/null
+++ b/app-emacs/yc/Manifest
@@ -0,0 +1 @@
+DIST yc-4.0.13.tar.gz 43916 SHA256 5afd06ea819bbf20f5cbfbcd3c60eb58a50b2ef093defc4c93bfdf8ab69444f3 SHA512 2b5430766bbdbc77a0ec3aba6d51478ff91186a257e75a2a3af25a885bbddbf7180fbdf3b0876c1a65c149060bb754a44f77bb399c43cc666bd0add40226ca32 WHIRLPOOL fcd0fbb6729f42cf752a4d590357202ea54763c243e5e29d9f6a9676e420e1b501c1579e0230b0e59d88c15cc7f106c8c1d32effd7411e708bada5f68f3dd380
diff --git a/app-emacs/yc/files/50yc-gentoo.el b/app-emacs/yc/files/50yc-gentoo.el
new file mode 100644
index 000000000000..33bd4a72a454
--- /dev/null
+++ b/app-emacs/yc/files/50yc-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; YC site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/yc/files/sample.dot.emacs-4 b/app-emacs/yc/files/sample.dot.emacs-4
new file mode 100644
index 000000000000..101532e704a6
--- /dev/null
+++ b/app-emacs/yc/files/sample.dot.emacs-4
@@ -0,0 +1,12 @@
+;;;; -*- mode: lisp-interaction; syntax: elisp; coding: iso-2022-7bit -*-
+
+;;;; Configuration for yc
+(setq yc-server-host "unix")
+;If you use inet socket service, enable the following line.
+;(setq yc-server-host "localhost")
+(setq yc-use-color t)
+(if (eq window-system 'x)
+ (setq yc-use-fence nil)
+ (setq yc-use-fence t))
+(load "yc")
+(global-yc-mode 1)
diff --git a/app-emacs/yc/files/sample.hosts.canna b/app-emacs/yc/files/sample.hosts.canna
new file mode 100644
index 000000000000..960d75f5266c
--- /dev/null
+++ b/app-emacs/yc/files/sample.hosts.canna
@@ -0,0 +1,2 @@
+localhost
+unix
diff --git a/app-emacs/yc/metadata.xml b/app-emacs/yc/metadata.xml
new file mode 100644
index 000000000000..df397ea3014c
--- /dev/null
+++ b/app-emacs/yc/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/yc/yc-4.0.13.ebuild b/app-emacs/yc/yc-4.0.13.ebuild
new file mode 100644
index 000000000000..b0bb30381b4a
--- /dev/null
+++ b/app-emacs/yc/yc-4.0.13.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="Yet another Canna client on Emacsen"
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-i18n/canna-3.6"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -e 's:$(CC) -o $(PROGRAM) $(OBJS):$(CC) ${CFLAGS} ${LDFLAGS} -o $(PROGRAM) $(OBJS):' -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dobin icanna || die
+ newdoc "${FILESDIR}"/sample.dot.emacs-4 sample.dot.emacs || die
+ dodoc "${FILESDIR}"/sample.hosts.canna || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "See the sample.dot.emacs file in /usr/share/doc/${PF}/."
+ elog
+ elog "And If you use unix domain socket for connecting the canna server, "
+ elog " please confirm that there's *no* following line in your .emacs ."
+ elog " (setq yc-server-host \"localhost\")"
+ elog
+ elog "If you use inet domain socket for connecting the canna server, "
+ elog " please modify as following in /etc/conf.d/canna."
+ elog " CANNASERVER_OPTS=\"-inet\""
+ elog " And create /etc/hosts.canna."
+ elog " (see the sample.hosts.canna file in /usr/share/doc/${PF}/)"
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}