summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-04-14 09:38:06 +0200
committerUlrich Müller <ulm@gentoo.org>2024-04-14 09:48:12 +0200
commit4f7ce08c648151e5b872a13be98b493b74d7e670 (patch)
tree9cf60c08406ad3f735170ad1cd0f31a793635430 /app-emacs/pymacs
parentdev-java/jimfs: new package, add 1.3.0 (diff)
downloadgentoo-4f7ce08c648151e5b872a13be98b493b74d7e670.tar.gz
gentoo-4f7ce08c648151e5b872a13be98b493b74d7e670.tar.bz2
gentoo-4f7ce08c648151e5b872a13be98b493b74d7e670.zip
app-emacs/pymacs: Locate rst2latex{,.py} command
Closes: https://bugs.gentoo.org/929979 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/pymacs-0.26-r5.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-emacs/pymacs/pymacs-0.26-r5.ebuild b/app-emacs/pymacs/pymacs-0.26-r5.ebuild
index 0cc4eacd125b..5d51948e9238 100644
--- a/app-emacs/pymacs/pymacs-0.26-r5.ebuild
+++ b/app-emacs/pymacs/pymacs-0.26-r5.ebuild
@@ -12,7 +12,7 @@ DESCRIPTION="A tool that allows both-side communication between Python and Emacs
HOMEPAGE="https://www.emacswiki.org/emacs/PyMacs
https://github.com/dgentry/Pymacs/"
-if [[ "${PV}" == *9999* ]] ; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/dgentry/${PN^}.git"
@@ -35,7 +35,7 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}/${PN}-0.26-setup.patch" )
+PATCHES=( "${FILESDIR}/${PN}-0.26-setup.patch" )
DOCS=( "${PN}.rst" )
SITEFILE="50${PN}-gentoo.el"
@@ -49,7 +49,9 @@ src_compile() {
elisp_src_compile
if use doc; then
- VARTEXFONTS="${T}/fonts" emake RST2LATEX="rst2latex.py" "${PN}.pdf"
+ # docutils 0.21.1 renamed rst2latex.py to rst2latex
+ local r2l=$(command -v rst2latex || command -v rst2latex.py || die)
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX="${r2l}" ${PN}.pdf
fi
}
@@ -57,5 +59,5 @@ src_install() {
distutils-r1_src_install
elisp_src_install
- use doc && dodoc "${PN}.pdf"
+ use doc && dodoc ${PN}.pdf
}