summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-11-11 11:58:44 +0100
committerUlrich Müller <ulm@gentoo.org>2019-11-11 11:58:44 +0100
commita23b6fa60f2a39a5e0bd6c4ffd9bc769bc996220 (patch)
tree6eb958a29f58a60ac7358503dde0a94d326eee02 /app-emacs/planner/planner-3.42-r1.ebuild
parentapp-emacs/remember: Update SRC_URI, bump EAPI to 7. (diff)
downloadgentoo-a23b6fa60f2a39a5e0bd6c4ffd9bc769bc996220.tar.gz
gentoo-a23b6fa60f2a39a5e0bd6c4ffd9bc769bc996220.tar.bz2
gentoo-a23b6fa60f2a39a5e0bd6c4ffd9bc769bc996220.zip
app-emacs/planner: Update SRC_URI, bump EAPI to 7.
Closes: https://bugs.gentoo.org/699684 Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/planner/planner-3.42-r1.ebuild')
-rw-r--r--app-emacs/planner/planner-3.42-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/planner/planner-3.42-r1.ebuild b/app-emacs/planner/planner-3.42-r1.ebuild
new file mode 100644
index 000000000000..5d5db2faa577
--- /dev/null
+++ b/app-emacs/planner/planner-3.42-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Maintain a local Wiki using Emacs-friendly markup"
+HOMEPAGE="https://www.emacswiki.org/emacs/PlannerMode"
+# taken from http://download.gna.org/planner-el/${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+RDEPEND=">=app-emacs/muse-3.02.6a
+ app-emacs/bbdb
+ app-emacs/emacs-w3m"
+BDEPEND="${RDEPEND}
+ sys-apps/texinfo"
+PDEPEND="app-emacs/remember"
+
+SITEFILE="80${PN}-gentoo.el"
+ELISP_TEXINFO="planner-el.texi"
+DOCS="AUTHORS COMMENTARY ChangeLog* NEWS README"
+
+src_compile() {
+ default
+}